Bug 214176 - Missing default 'server signing' option aborts system-config-samba to be executed.
Summary: Missing default 'server signing' option aborts system-config-samba to be exec...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-samba   
(Show other bugs)
Version: 4.4
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Nils Philippsen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-06 12:58 UTC by Jose Plans
Modified: 2007-11-17 01:14 UTC (History)
1 user (show)

Fixed In Version: RHBA-2007-0070
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 19:23:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch addinng the defaults missing line. (435 bytes, patch)
2006-11-06 12:58 UTC, Jose Plans
no flags Details | Diff
patch adding all the options known by samba / testparm. (4.21 KB, patch)
2006-12-12 15:30 UTC, Jose Plans
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0070 normal SHIPPED_LIVE system-config-samba bug fix update 2007-05-01 14:06:50 UTC

Description Jose Plans 2006-11-06 12:58:33 UTC
Description of problem:

 When adding to a /etc/samba/smb.conf file "server signing = Auto",
system-config-samba aborts and presents a python backtrace.
 The backtrace shows there's a default attribute missing on the defaults
presented to this tool.

Version-Release number of selected component (if applicable):
system-config-samba-1.2.21-1

How reproducible:
Always.

Steps to Reproduce:
1. Edit /etc/samba/smb.conf
2. Add in globals "server signing = Auto"
3. Execute system-config-samba
  
Actual results:
--
Traceback (most recent call last):
  File "/usr/share/system-config-samba/system-config-samba.py", line 41, in ?
    mainWindow.MainWindow(debug_flag)
  File "/usr/share/system-config-samba/mainWindow.py", line 75, in __init__
    self.samba_data = sambaParser.SambaParser(self)
  File "/usr/share/system-config-samba/sambaParser.py", line 41, in __init__
    self.parseFile()
  File "/usr/share/system-config-samba/sambaParser.py", line 75, in parseFile
    token = self.createToken(line)
  File "/usr/share/system-config-samba/sambaParser.py", line 147, in createToken
    token = sambaToken.SambaToken(sambaToken.SambaToken.SAMBA_TOKEN_KEYVAL,
(name, value), self.parent)
  File "/usr/share/system-config-samba/sambaToken.py", line 36, in __init__
    raise AttributeError, value
AttributeError: ('server signing', 'Auto')
--

Expected results:
Some tracebacks ;-) but at least be able to use the tool.

Additional info:
Attached patch that adds to the tool the missing line.

     Jose

Comment 1 Jose Plans 2006-11-06 12:58:33 UTC
Created attachment 140457 [details]
patch addinng the defaults missing line.

Comment 5 Jose Plans 2006-12-12 15:30:55 UTC
Created attachment 143400 [details]
patch adding all the options known by samba / testparm.

Comment 6 Nils Philippsen 2006-12-12 15:42:54 UTC
I've cloned this bug for RHEL5 beta -- it wouldn't be good to have this fixed in
a RHEL4 update but not in RHEL5.

Comment 7 Nils Philippsen 2006-12-13 13:17:00 UTC
The cloned bug is #219308.

Comment 9 Nils Philippsen 2007-01-08 16:25:30 UTC
I'm working on a more general solution than simply adding some options every now
and then, see bug #219308. I'm planning to backport these changes once they're done.

Comment 10 Nils Philippsen 2007-01-15 10:14:30 UTC
Held up by regression (bug #222595) introduced with new generalized solution.

Comment 11 Nils Philippsen 2007-01-22 15:27:41 UTC
system-config-samba-1.2.26 built in dist-4E-qu-candidate

Comment 12 Nils Philippsen 2007-01-22 16:42:49 UTC
system-config-samba-0.EL4.3 even

Comment 14 Nils Philippsen 2007-01-22 16:57:52 UTC
reverted to system-config-samba-1.2.21-1.el4.1 which is building right now.

Comment 18 Red Hat Bugzilla 2007-02-08 19:23:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0070.html


Comment 20 Issue Tracker 2007-07-03 14:12:41 UTC
Hi,

The problem is fixed and my crm ticket is closed, therefore I closed this
IT.

Thanks,

Sebastien.

Internal Status set to 'Resolved'
Status set to: Closed by Tech
Resolution set to: 'RHEL 4 U4'

This event sent from IssueTracker by saime 
 issue 106056


Note You need to log in before you can comment on or make changes to this bug.