Bug 214202 - Intel Core2 has L2 cache, not L3 [NEEDINFO]
Intel Core2 has L2 cache, not L3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: x86info (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 10:21 EST by Jakub Jelinek
Modified: 2015-01-04 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:02:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (jakub)


Attachments (Terms of Use)

  None (edit)
Description Jakub Jelinek 2006-11-06 10:21:05 EST
Family: 6 Model: 15 Stepping: 5 Type: 0 Brand: 0
CPU Model: Core 2 Extreme E6800/X6800 [B1] Original OEM
Feature flags:
 fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflsh ds acpi mmx fxsr sse sse2 ss ht tm pbe sse3 monitor ds-cpl vmx est tm2 ssse3 cx16 xTPR
Extended feature flags:
 SYSCALL xd em64t lahf_lm
Cache info
 L1 Instruction cache: 32KB, 8-way associative. 64 byte line size.
 L1 Data cache: 32KB, 8-way associative. 64 byte line size.
 L3 unified cache: 4MB, 16-way associative. 64 byte line size.
TLB info
 Instruction TLB: 4x 4MB page entries, or 8x 2MB pages entries, 4-way associative
 Instruction TLB: 4K pages, 4-way associative, 128 entries.
 Data TLB: 4MB pages, 4-way associative, 32 entries
 L0 Data TLB: 4MB pages, 4-way set associative, 16 entries
 L0 Data TLB: 4MB pages, 4-way set associative, 16 entries
 Data TLB: 4K pages, 4-way associative, 256 entries.
 64 byte prefetching.
The physical package supports 2 logical processors 

But this CPU doesn't have L3 cache and no L2, it has 4MB L2 cache.
According to Ulrich, current Intel manuals say:
49h 3-level cache: 4 MB, 16-way set associative, 64-byte line size (Intel Xeon processor MP, Family F, Model 6)
      and
     2-level cache: 4 MB, 16-way set associative, 64-byte line size
Comment 1 Dave Jones 2007-03-26 02:45:50 EDT
sigh, yet more special cases.
Not sure of a clean way to do this without significantly rewriting the cache
handling.

We could be really cheap, and just print out something like

"L2/L3 unified cache" or similar, but that feels like a cop-out.
Comment 2 RHEL Product and Program Management 2014-03-07 07:39:23 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 RHEL Product and Program Management 2014-06-02 09:02:28 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.