This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 214213 - Corrupted user-name
Corrupted user-name
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mod_auth_kerb (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 11:26 EST by Joe Orton
Modified: 2013-04-12 14:53 EDT (History)
0 users

See Also:
Fixed In Version: RHBA-2007-0517
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-05 11:36:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joe Orton 2006-11-06 11:26:15 EST
+++ This bug was initially created as a clone of Bug #214207 +++

Description of problem:

mod_auth_kerb seems to corrupt the username:

| XXXXXX - ensc@XXXXX [06/Nov/2006:16:55:32 +0100] "GET ...
| XXXXXX - \x02 [06/Nov/2006:16:55:34 +0100]

Logfile shows

| ... using cached name , referer: ...
| ... using cached name o_mini.png, ...

like entries.


This seems to be caused by the -cache patch which does:

|  MK_USER = apr_pstrdup(r->pool, output_token.value);
|  ...
|      rv = apr_pool_userdata_set(r->user, NAMEKEY, NULL, r->connection->pool);
| ----
|      if (apr_pool_userdata_get(&data, NAMEKEY, r->connection->pool) == APR_SUCCESS


When having a multi-request connection, the 'r->pool' might be freed
while the 'r->connection->pool' is still alive and returns corrupted
memory.

I suggest to write

|-  MK_USER = apr_pstrdup(r->pool, output_token.value);
|+  MK_USER = apr_pstrdup(r->connection->pool, output_token.value);

which seems to fix the problem for me.


Version-Release number of selected component (if applicable):

mod_auth_kerb-5.1-3

-- Additional comment from jorton@redhat.com on 2006-11-06 11:11 EST --
Good catch, thanks!
Comment 3 RHEL Product and Program Management 2007-05-23 08:46:20 EDT
Since Keyword Regression exists, this is a blocker,
not an exception.  Cleared exception flag.
Set blocker flag."
Comment 4 Daniel Riek 2007-06-06 09:33:11 EDT
Removing the blocker and requesting FasTrack instead.
Comment 9 Red Hat Bugzilla 2007-07-05 11:36:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0517.html

Note You need to log in before you can comment on or make changes to this bug.