Bug 214233 - Bad script in /usr/lib/rpm/redhat/find-requires
Summary: Bad script in /usr/lib/rpm/redhat/find-requires
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jon Masters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-06 18:32 UTC by H.J. Lu
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: f7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-19 18:19:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description H.J. Lu 2006-11-06 18:32:29 UTC
/usr/lib/rpm/redhat/find-requires in redhat-rpm-config-8.0.45-6 has

if [ "$1" ]
then
   package_name = "$1"
fi

It leads to

/usr/lib/rpm/redhat/find-requires: line 10: package_name: command not found
Finding  Requires: /usr/lib/rpm/redhat/find-requires kernel

when building noarch kernel rpm. This change

d[hjl@gnu-2 kernel-FC5]$ diff -up /tmp/find-requires
/usr/lib/rpm/redhat/find-reuires
--- /tmp/find-requires  2006-11-06 10:27:50.000000000 -0800
+++ /usr/lib/rpm/redhat/find-requires   2006-11-06 10:27:58.000000000 -0800
@@ -7,7 +7,7 @@
 
 if [ "$1" ]
 then
-   package_name = "$1"
+   package_name="$1"
 fi
 
 ulimit -c 0

works for me.

Comment 1 Jon Masters 2006-11-10 11:23:02 UTC
Oops. Got fixed in devel (I think, will check) but didn't get into FC6. I'll
have to make sure this goes into the next update.


Note You need to log in before you can comment on or make changes to this bug.