Bug 214243 - Advanced install loops at install sample entries
Summary: Advanced install loops at install sample entries
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: Install/Uninstall (Show other bugs)
(Show other bugs)
Version: 1.0.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Keywords:
: 214007 (view as bug list)
Depends On:
Blocks: 152373 fds104tracking 240316
TreeView+ depends on / blocked
 
Reported: 2006-11-06 19:20 UTC by Rich Megginson
Modified: 2015-12-07 16:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 16:42:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (2.65 KB, patch)
2006-11-06 19:30 UTC, Rich Megginson
no flags Details | Diff

Description Rich Megginson 2006-11-06 19:20:43 UTC
When doing setup in Advanced mode, the installer asks if you want to install
them sample entries, then asks "Type the full path and filename, the word
suggest, or the word none".  No matter what you type there, it goes back and
asks to install the sample entries again, then gets stuck in a loop.

Comment 1 Rich Megginson 2006-11-06 19:30:41 UTC
Created attachment 140498 [details]
diffs

There were a couple of problems.  The first problem is that askPopulate is not
a YesNo dialog, it is just a general Input dialog.  The second problem is that
askPopulateSetup sets the input buffer size greater than the static buffer used
to hold the input in the Dialog class, which is defined as char _buf[MED_BUF]. 
So the solution is to set the InputLen to be MED_BUF-1, which allows for the
trailing null as well.

Comment 2 Noriko Hosoi 2006-11-06 19:46:35 UTC
Looks good.

Comment 3 Nathan Kinder 2006-11-06 19:54:01 UTC
*** Bug 214007 has been marked as a duplicate of this bug. ***

Comment 4 Nathan Kinder 2006-11-06 19:56:43 UTC
Looks good.

Comment 5 Rich Megginson 2006-11-06 20:40:05 UTC
Reviewed by: nhosoi (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: There were a couple of problems.  The first problem is that
askPopulate is not
a YesNo dialog, it is just a general Input dialog.  The second problem is that
askPopulateSetup sets the input buffer size greater than the static buffer used
to hold the input in the Dialog class, which is defined as char _buf[MED_BUF].
So the solution is to set the InputLen to be MED_BUF-1, which allows for the
trailing null as well.
Platforms tested: FC5
Flag Day: no
Doc impact: no 

Checking in ux-dialog.cc;
/cvs/dirsec/ldapserver/ldap/cm/newinst/ux-dialog.cc,v  <--  ux-dialog.cc
new revision: 1.10; previous revision: 1.9
done
Checking in ux-dialog.h;
/cvs/dirsec/ldapserver/ldap/cm/newinst/ux-dialog.h,v  <--  ux-dialog.h
new revision: 1.5; previous revision: 1.4
done


Comment 6 Anh Nguyen 2007-11-30 23:29:09 UTC
Tested with the following packages. Custom installation works fine. Changed
status to VERIFIED.
1196462481 redhat-ds-console-8.0.0-8.el5dsrv Fri Nov 30 2007 
1196462482 redhat-admin-console-8.0.0-9.el5dsrv Fri Nov 30 2007 
1196462482 redhat-idm-console-1.0.0-15.el5idm Fri Nov 30 2007 



Note You need to log in before you can comment on or make changes to this bug.