Bug 21426 - Strange warning in g77
Summary: Strange warning in g77
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 21898 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-28 14:48 UTC by Need Real Name
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 21:18:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2000:132 normal SHIPPED_LIVE Bug fixing update of GCC 2.96 2000-12-19 05:00:00 UTC

Description Need Real Name 2000-11-28 14:48:45 UTC
After installing the new glibc (RHBA-2000:079-08) , fortran programs give a
strange warning at compile time.
Any program like 

      program main
      print*,'Helo world'
      end

Will compile saying

>g77 main.f
>/usr/lib/gcc-lib/i386-redhat-linux/2.96/libg2c.a(open.o): In function
`f_open':
>open.o(.text+0x4e6): the use of `tempnam' is dangerous, better use
`mkstemp'
>
>Compilation finished at Tue Nov 28 15:31:37

Best regards
Thomas A. Poulsen
Dpt. of Solid Mech.
Tech. Univ. of Denmark

Comment 1 Jakub Jelinek 2000-11-28 16:24:37 UTC
libf2c uses tempnam internally and glibc warns about uses of this function
during link time.
gcc-g77-2.96-65 will include Toon Moene's fix for this.

Comment 2 matthew jull 2000-12-08 21:18:30 UTC
*** Bug 21898 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.