This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 214297 - Xvfb -fbdir - option disappeared
Xvfb -fbdir - option disappeared
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 17:43 EST by al
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.1-47.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-25 19:04:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description al 2006-11-06 17:43:31 EST
Description of problem:
According to man Xvfb the framebuffer directory can be specified using -fbdir
option. If I try to start Xvfb with:
/usr/bin/Xvfb -nolisten inet6 :$N -ac -screen 0 $SIZE -fbdir $FBD
I get:
Fatal server error:
Unrecognized option: -fbdir

It used to work in earlier versions.

Version-Release number of selected component (if applicable):

xorg-x11-server-Xvfb-1.0.1-9.fc5.5

How reproducible:

always reproducible

Steps to Reproduce:
1. /usr/bin/Xvfb -fbdir /tmp
2.
3.
  
Actual results:

Fatal server error:
Unrecognized option: -fbdir

Expected results:
normal start of Xvfb

Additional info:
Fedora Core release 5 (Bordeaux)
Kernel: 2.6.17-1.2187_FC5

libXau-1.0.0-2.2
libXdmcp-1.0.0-2.2
libXfont-1.0.0-3
glibc-2.4-11
liblbxutil-1.0.0-2.2
Comment 1 Adam Tkac 2006-11-30 10:42:55 EST
I can verify that this problem still exists in fc5, fc6, devel, rhel-5 etc... I
can't find how I can specify Xvfb's output file. Is any new option? Or in
current  versions isn't anyway how map Xvfb's output to file? Thanks for info
Comment 2 Adam Tkac 2007-02-19 15:49:44 EST
I see progress here. I'm not able to reproduce this bug with latest Xvfb
(xorg-x11-server-Xvfb-1.1.1-47.4.fc6, i386) so I think this is now fixed and you
could close this bug...

Regards, Adam

Note You need to log in before you can comment on or make changes to this bug.