Bug 214325 - yumex gui updates get stuck sometimes
yumex gui updates get stuck sometimes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 20:32 EST by Tom Horsley
Modified: 2008-03-13 03:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: 2.0.4-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:38:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2006-11-06 20:32:28 EST
Description of problem:

This is a weird one - sometimes (most often I think during the
"processing metadata" feedback) the yumex gui will just stop
updating, like it is no longer getting any events. The progress
bar will just stop moving and the system monitor won't show any
disk or network activity and yumex won't be getting any cpu time.

If I wave the mouse over the window, it starts working again
(like the focus change event from the mouse movement poked
it and woke it up).

Version-Release number of selected component (if applicable):

yumex-1.1.7-1.0.fc6

How reproducible:

Completely random, never know when or if it will happen.

Steps to Reproduce:
1. Run yumex until it appears to freeze up.
2. Move focus in or out of window and watch it start up again.
3.
  
Actual results:

Sometimes freezes.

Expected results:

Be nice if I could leave it unattended and not have it freeze up
while I'm gone :-).

Additional info:

I put this down as just a coincidence between the mouse movement
and the gui starting to work again until I'd seen it happen too many
times after installing and updating lots of FC6 systems.
Comment 1 Tim Lauridsen 2006-11-07 02:25:42 EST
I seen it happen a couple of times, but have not found the reason yet, it is
always while the the yum C metadata parser is running.
I will keep looking.
Comment 2 Gilboa Davara 2006-11-19 09:35:55 EST
Same here.

As weird as it sounds, it -only- happens on a very low end Inspiron 7000 laptop
that (PII/366, 256MB) uses IceWM as its DE.

BTW, pressing any key (shift, space) will also wake yumex up.

- Gilboa
Comment 3 Samuel Sieb 2006-12-03 16:26:25 EST
I've seen this at least once on pretty much every computer I've put FC6 on.
Comment 4 Tim Lauridsen 2007-01-04 04:16:48 EST
Please test with the current yumex 1.9.1 Prerelease.

You can get it here:
http://www.yum-extender.org/dnl/yumex/devel/

To see if it works better, i think it can be caused by the yum action is run in
a background thread i yumex 1.2.1.
Comment 5 Tom Horsley 2007-01-04 18:35:07 EST
Well, I downloaded the noarch rpm from there and installed it, and so
far it has managed to get through 1 update without getting hung, so
that's a good sign.
Comment 6 Gilboa Davara 2007-01-08 04:38:54 EST
I tried the 1.9.1, and I'm not sure it solves the problem.
1.9.1 seems to run slower then 1.2.1 on my PII test machine.
I can't say if it stalls like 1.2.1, but it took me 4 hours to finish a 40
package update...

- Gilboa
Comment 7 Philip Walden 2007-02-23 18:47:26 EST
I am also seeing this problem with yumex 1.2.2 on FC6. I also see the an extreme
slow down over the FC5 version of yumex
Comment 8 Laurent Rineau 2007-11-12 07:31:16 EST
I think that one can close this bug. It is fixed for a long time in Rawhide (I 
am running F-8, and yumex rocks). However, it is reported against 
Fedora Core 6, which is still supported, AFAIK. Tim, can you update the status 
of this bug?
Comment 9 Samuel Sieb 2007-11-12 12:05:15 EST
It also still happens on F7.
Comment 10 Tom Horsley 2007-11-12 18:25:44 EST
Just today when I installed F8 on my system at work and ran yumex, it
got up to 100% in the initial loading of all the repo data, then just
sat there for a while. I was working on something else, so didn't fool
with it, but eventually came back to it after about 15 minutes and it
was still sitting there saying 100%. As soon as I moved the mouse over
it, it finally switched to the view of available updates, so it does
still seem to happen (but a lot less frequently I think).
Comment 11 Samuel Sieb 2007-11-12 21:00:38 EST
Yes, I just noticed it in 8 today as well.  One thing that might be related is
that the window, starting at the current package progress bar, bounces around a
lot, sometimes using so much CPU time that it slows the installation down.
Comment 12 Samuel Sieb 2007-11-25 00:08:00 EST
I did a F8 install today, installed yumex, and did an upgrade with it.  This
computer had a 1GHz Athlon and only 256MB of RAM which made things somewhat
slow.  yumex was pausing all the time, even before the bouncing progress bar
part.  It even paused while running through the dependency checking.
Comment 13 Andrew White 2007-12-06 14:45:13 EST
I've had it happen in Yumex 2.0.3 on fedora 8. I told yumex to update overnight
and when I returned in the morning it had neglected to progress from a failed
mirror(of which there were two) on to the next download. I checked the timestamp
on the download before that and it had finished that at 03:28:09 in the morning
and went to "13:13:17 : Trying other mirror." only after I switched focus to
that window this afternoon.
Comment 14 Fedora Update System 2008-02-21 09:00:38 EST
yumex-2.0.4-1.fc8 has been submitted as an update for Fedora 8
Comment 15 Fedora Update System 2008-02-21 09:04:49 EST
yumex-2.0.4-1.fc7 has been submitted as an update for Fedora 7
Comment 16 Fedora Update System 2008-02-25 19:24:05 EST
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-1940
Comment 17 Fedora Update System 2008-03-13 03:38:36 EDT
yumex-2.0.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2008-03-13 03:47:53 EDT
yumex-2.0.4-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.