Bug 214332 - BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug()
BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug()
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 207916 218178 220702 220830 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-06 21:21 EST by Shantanu Goel
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 11:15:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shantanu Goel 2006-11-06 21:21:22 EST
Description of problem:
Saw the following backtrace on my Core Duo Mac Mini running
kernel-2.6.18-1.2798.fc6.

BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug() (Not tainted)
 [<c04051db>] dump_trace+0x69/0x1af
 [<c0405339>] show_trace_log_lvl+0x18/0x2c
 [<c04058ed>] show_trace+0xf/0x11
 [<c04059ea>] dump_stack+0x15/0x17
 [<c043c220>] unlock_cpu_hotplug+0x46/0x6f
 [<df3c62a7>] do_dbs_timer+0x127/0x16b [cpufreq_ondemand]
 [<c0433c30>] run_workqueue+0x83/0xc5
 [<c0434520>] worker_thread+0xd9/0x10d
 [<c04369f3>] kthread+0xc0/0xed
 [<c0404dab>] kernel_thread_helper+0x7/0x10
DWARF2 unwinder stuck at kernel_thread_helper+0x7/0x10
Leftover inexact backtrace:
Comment 1 Doug Chapman 2006-11-27 12:00:38 EST
FYI, looks like rhts hit this on ia64 as well.  changing from i386 to "all".

details of the panic on olympia1 via rhts:

http://rhts.lab.boston.redhat.com/cgi-bin/rhts/test_log.cgi?id=933285
Comment 2 Linda Wang 2006-12-04 12:12:25 EST
*** Bug 218178 has been marked as a duplicate of this bug. ***
Comment 4 Davide Rossetti 2006-12-05 09:53:16 EST
I got a couple of these in a raw in less than 24 hours. I'm rebooting now.

>uname -a
Linux hokusai 2.6.18-1.2849.fc6 #1 SMP Fri Nov 10 12:34:46 EST 2006 x86_64
x86_64 x86_64 GNU/Linux

Intel(R) Pentium(R) D CPU 3.00GHz

BUG: warning at kernel/cpu.c:56/unlock_cpu_hotplug() (Tainted: P     )

Call Trace:
 [<ffffffff802691bd>] show_trace+0x34/0x47
 [<ffffffff802691e2>] dump_stack+0x12/0x17
 [<ffffffff802a04ea>] unlock_cpu_hotplug+0x47/0x74
 [<ffffffff883702aa>] :cpufreq_ondemand:do_dbs_timer+0x11c/0x174
 [<ffffffff8024be61>] run_workqueue+0x9a/0xed
 [<ffffffff80248848>] worker_thread+0xf0/0x122
 [<ffffffff80232872>] kthread+0xf6/0x12a
 [<ffffffff8025cda5>] child_rip+0xa/0x11
DWARF2 unwinder stuck at child_rip+0xa/0x11
Leftover inexact backtrace:
 [<ffffffff8029b9e8>] keventd_create_kthread+0x0/0x66
 [<ffffffff8023277c>] kthread+0x0/0x12a
 [<ffffffff8025cd9b>] child_rip+0x0/0x11
Comment 5 Dan Carpenter 2006-12-05 15:48:03 EST
This is possibly related to bug 215274
Comment 6 Prarit Bhargava 2006-12-06 10:34:31 EST
Known issue, sorry for the cut-and-paste:

Posted the following patch to lhcs-devel (cut-and-paste):

--- linux-2.6.18.ia64-orig/kernel/cpu.c.orig	2006-10-31 10:57:37.000000000 -0500
+++ linux-2.6.18.ia64/kernel/cpu.c	2006-10-31 10:57:46.000000000 -0500
@@ -58,8 +58,8 @@ void unlock_cpu_hotplug(void)
 		recursive_depth--;
 		return;
 	}
-	mutex_unlock(&cpu_bitmask_lock);
 	recursive = NULL;
+	mutex_unlock(&cpu_bitmask_lock);
 }
 EXPORT_SYMBOL_GPL(unlock_cpu_hotplug);

---

For some reason this hasn't made it into the kernel.  I'll ping akpm about it.

P.
Comment 7 Prarit Bhargava 2006-12-06 11:15:27 EST
Fixed in 2.6.19.  Will be in next release.

P.
Comment 8 Jarod Wilson 2007-01-02 16:24:30 EST
*** Bug 220702 has been marked as a duplicate of this bug. ***
Comment 9 Jarod Wilson 2007-01-02 16:26:51 EST
*** Bug 207916 has been marked as a duplicate of this bug. ***
Comment 10 Jarod Wilson 2007-01-02 16:26:56 EST
*** Bug 220830 has been marked as a duplicate of this bug. ***
Comment 11 Need Real Name 2007-01-14 22:13:22 EST
I can still see this bug with 2.6.18-1.2869.fc6 #1 SMP:
Jan 15 03:34:35 localhost kernel: BUG: warning at
kernel/cpu.c:56/unlock_cpu_hotplug() (Not tainted)
Jan 15 03:34:35 localhost kernel:  [<c04051db>] dump_trace+0x69/0x1af
Jan 15 03:34:35 localhost kernel:  [<c0405339>] show_trace_log_lvl+0x18/0x2c
Jan 15 03:34:35 localhost kernel:  [<c04058ed>] show_trace+0xf/0x11
Jan 15 03:34:35 localhost kernel:  [<c04059ea>] dump_stack+0x15/0x17
Jan 15 03:34:35 localhost kernel:  [<c043c25c>] unlock_cpu_hotplug+0x46/0x6f
Jan 15 03:34:35 localhost kernel:  [<f8a682a7>] do_dbs_timer+0x127/0x16b
[cpufreq_ondemand]
Jan 15 03:34:35 localhost kernel:  [<c0433c18>] run_workqueue+0x83/0xc5
Jan 15 03:34:35 localhost kernel:  [<c0434508>] worker_thread+0xd9/0x10d
Jan 15 03:34:35 localhost kernel:  [<c04369db>] kthread+0xc0/0xed
Jan 15 03:34:35 localhost kernel:  [<c0404dab>] kernel_thread_helper+0x7/0x10
Jan 15 03:34:35 localhost kernel: DWARF2 unwinder stuck at
kernel_thread_helper+0x7/0x10

It happened 8 times, but last one was fatal (lot of hard drive activity,
computer became non-responsive).
Comment 12 Seán O Sullivan 2007-01-17 10:27:30 EST
Occurred in RHEL 5 beta 2 also.
Linux badger.red-hat.eu 2.6.18-1.2747.el5 #1 SMP Thu Nov 9 18:55:30 EST 2006
i686 athlon i386 GNU/Linux
Dual Opteron 246, 2Ghz

Note You need to log in before you can comment on or make changes to this bug.