Bug 214347 - Xencomm patch breaks PV-on-HVM
Xencomm patch breaks PV-on-HVM
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.0
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Aron Griffis
:
: 215518 (view as bug list)
Depends On:
Blocks: 184190 219640
  Show dependency treegraph
 
Reported: 2006-11-07 00:40 EST by Nagasima Junichi
Modified: 2010-10-22 02:51 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 17:02:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nagasima Junichi 2006-11-07 00:40:56 EST
Description of problem:

Xencomm patch (Bugzilla Bug 212540) breaks PV-on-HVM
because of hypercall interface mismatch.
Then it is necessary to apply Xencomm mini patch.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Atsushi SAKAI 2006-11-07 00:54:36 EST
xencomm_mini patch means
xen-unstable CS11973 and 11974                 
http://xenbits.xensource.com/xen-unstable.hg?cs=9e8fdcc46fa3
http://xenbits.xensource.com/xen-unstable.hg?cs=7c2a5f96a192

It should be applied above patches after Bugzilla Bug 212540 patch is applied.
Without this patch, PV-on-HVM does not work on xencomm platform.
Comment 2 Larry Troan 2006-11-14 10:13:37 EST
*** Bug 215518 has been marked as a duplicate of this bug. ***
Comment 3 Larry Troan 2006-11-14 10:16:22 EST
TAM believes this is a feature. 

Does Engineering concur xencomm_mini function is a feature? If so, this is a 5.1
request as feature freeze for RHEL5GA occurred some time ago.


Comment 4 Larry Troan 2006-11-14 10:19:03 EST
Changing severity to agree with Issue Tracker sev=2.
Comment 5 Nagasima Junichi 2006-11-15 02:16:13 EST
(In reply to comment #3)
> TAM believes this is a feature. 
> 
> Does Engineering concur xencomm_mini function is a feature? If so, this is a 5.1
> request as feature freeze for RHEL5GA occurred some time ago.
> 
No.
Xencomm patch (Bugzilla Bug 212540) causes a hypercall interface mismatch and
then PV-on-HVM does not work. So I think the xencomm_mini function is a bug fix.


Comment 6 Nagasima Junichi 2006-11-15 03:02:58 EST
(In reply to comment #5)
> (In reply to comment #3)
> > TAM believes this is a feature. 
> > 
> > Does Engineering concur xencomm_mini function is a feature? If so, this is a 5.1
> > request as feature freeze for RHEL5GA occurred some time ago.
> > 
> No.
> Xencomm patch (Bugzilla Bug 212540) causes a hypercall interface mismatch and
> then PV-on-HVM does not work. So I think the xencomm_mini function is a bug fix.
> 
Comment 7 Prarit Bhargava 2006-11-17 14:29:26 EST
These are definately bug fixes.  Reassigning to Aron.

P.
Comment 8 Aron Griffis 2006-11-17 15:02:24 EST
These are already in the patch set in Bug 212540, I believe.  Look at
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=139541

Am I wrong?
Comment 9 Aron Griffis 2006-11-17 15:14:20 EST
I see the problem. 
http://xenbits.xensource.com/ext/xen-ia64-unstable.hg?cs=7c2a5f96a192 contains
patches to the unmodified_drivers tree, which is currently not handled by my
import script.  I'll fix that.
Comment 10 Rik van Riel 2006-11-17 17:02:17 EST
Could somebody please tell me *which* PV-on-HVM drivers get broken?

As far as I know, there are no PV-on-HVM drivers in RHEL5, so I do not
understand how they could get broken by some other change...
Comment 11 Larry Troan 2006-11-20 14:29:01 EST
Per discussion with Prarit and Aron,
Bug 214347: 
> Status-NEW, no patch but Aron sees problem and will fix.
> TAM feels this is a Feature which means 5.1 but it depends on whether
> xencomm_mini is a feature or not. Comments?

Based on above, Aron pleas ACK for devel and describe fix; 
QA please ACK/NAK accordingly.
Comment 12 Jay Turner 2006-11-20 16:02:29 EST
Need some clarification on the question Rik poses in comment 10 before ack/nak.
Comment 15 Nagasima Junichi 2006-11-20 23:52:15 EST
Patch CS11973 included in xencomm_mini patch is a correction to cancel
the build error of PV-on-HVM. Therefore, CS11973 is bug fix.
CS11973 is in patch is from xen-IA64-unstable, and take patch is from
xen-IA64-unstable, please.

CS11974 is a correction of PV-on-HVM for the following corrections
registered in Issues.
CS11974 is necessary PV-on-HVM create with RHEL5.

106716 [RHEL5 beta] Can't use PV-on-HVM driver on IPF for the previous
linux(like as RHEL4 U2 or U4)
106600 [RHEL5 beta] Can't use PV-on-HVM driver for the previous
linux(like as RHEL4 U2 or U4)
Comment 16 Atsushi SAKAI 2006-11-21 00:24:28 EST
About #15
Please replace word about Cset
from xen-ia64-unstable to xen-unstable.

Above 2Csets are 
xen-unstable 11973 and 11974 

Thanks
Comment 18 Larry Troan 2006-11-28 10:03:52 EST
Per the above discussions (comments 11-15), THIS IS A BUG, not a feature. Will
ask this be addressed during beta.

Removing keyword=FEATURE and setting flag for 5.0 consideration.

Aron, please attach patch you discussed in comment #9 and devel ACK so QA can
ACK/NAK as well. 
Comment 19 RHEL Product and Program Management 2006-11-28 10:30:38 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 21 Aron Griffis 2006-11-30 08:39:51 EST
(In reply to comment #15)
> Patch CS11973 included in xencomm_mini patch is a correction to cancel
> the build error of PV-on-HVM. Therefore, CS11973 is bug fix.
> CS11973 is in patch is from xen-IA64-unstable, and take patch is from
> xen-IA64-unstable, please.
> 
> CS11974 is a correction of PV-on-HVM for the following corrections
> registered in Issues.
> CS11974 is necessary PV-on-HVM create with RHEL5.
> 
> 106716 [RHEL5 beta] Can't use PV-on-HVM driver on IPF for the previous
> linux(like as RHEL4 U2 or U4)
> 106600 [RHEL5 beta] Can't use PV-on-HVM driver for the previous
> linux(like as RHEL4 U2 or U4)

I would like to ACK this, but I don't see the problem yet.  The xen/ia64
patchset being tested on ipf-virtualization ML includes:

11804 [IA64] Xencomm fixes for HVM PV-drivers and driver domain.
11805 [IA64] Xencomm fixes for HVM PV-drivers

These are the changeset numbers from xen-ia64-unstable, but they match the
changesets from xen-unstable.  Unless Fujitsu can explain what is lacking, this
bug is a no-op
Comment 22 Nagasima Junichi 2006-12-01 06:41:49 EST
I want to make sure you will merge 2Csets(xen-unstable 11973 and 11974).
I wish the same patches to apply.
If so  there is no problem.
Comment 23 Larry Troan 2006-12-03 18:12:54 EST
Escalating for RHEL5.0 consideration per Thursday's RHEL5 meeting.

We need a DEVEL and QE ACKs (Aron/Prarit or your management + QA). 
Per comment #22, looks like additional work is involved but patchs appear
available. QA needs final patch to determine if acceptable at this late stage
for RHEL5.0 inclusion before giving their ACK. 
Comment 24 Aron Griffis 2006-12-04 18:00:56 EST
(In reply to comment #23)
> Per comment #22, looks like additional work is involved but patchs appear
> available. QA needs final patch to determine if acceptable at this late stage
> for RHEL5.0 inclusion before giving their ACK. 

I think this is a misunderstanding of Nagasima Junichi's comment.  These patches
are already in bug 210637.  I believe he was just making sure they're being
applied, and if so, there's no problem.
Comment 27 Jay Turner 2006-12-06 17:09:45 EST
QE ack for RHEL5.
Comment 29 Nagasima Junichi 2006-12-14 23:35:04 EST
We should apply the patch of xen-unstable(11974).
  
  Thank you.
Comment 31 Aron Griffis 2006-12-19 17:02:06 EST
(In reply to comment #29)
> We should apply the patch of xen-unstable(11974).

There are no PV-on-HVM drivers in RHEL5, so this patch doesn't apply.  This bug
is invalid.

Note You need to log in before you can comment on or make changes to this bug.