Bug 214361 - "acpi" and "apic" can't be changed by user with virt-manager
"acpi" and "apic" can't be changed by user with virt-manager
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
i386 All
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
Brian Brock
:
: 214362 (view as bug list)
Depends On:
Blocks: 218773
  Show dependency treegraph
 
Reported: 2006-11-07 04:07 EST by Toshiyuki Shirae
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-09 16:04:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toshiyuki Shirae 2006-11-07 04:07:05 EST
Description of problem:
In virt-manager, "acpi" and "apic" are always set as "1".  
In some cases, it's necessary to set "acpi" and "apic" as 0, for example a 
windows domain.  

Version-Release number of selected component (if applicable):
xen-3.0.3-0.1.rc3  
libvirt-0.1.7-2  
virt-manager-0.2.3-2.fc6  
python-virtinst-0.95.0-1.fc6  

How reproducible:
always  

Steps to Reproduce:
1.Launch virt-manager and connect to the local xen instance.  
2.Click "New" button and create a VM.  
3.The items were set as follows.  
  start up memory: 512
  maximum memory : 512
  domain name    : winsrv2k3
  virtualization method : Fully virtualized
  installation source   : /dev/hda
  disk type      : file
  disk image     : /root/winsrv2k3.img
  disk size      : 4000
  vcpus          : 1
4.Refer the configuration file under "/etc/xen".  

Actual results:
The value of "acpi" and "apic" are always set as "1" by virt-manager.  

Expected results:
The value of "acpi" and "apic" can be changed by user with virt-manager.  

Additional info:
The configuration file, "winsrv2k3", is attached with this report.
Comment 1 Toshiyuki Shirae 2006-11-07 04:35:35 EST
*** Bug 214362 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Berrange 2006-11-15 11:55:50 EST
We don't plan to expose the 'acpi' and 'apic' settings directly through the
virt-manager UI, because no average user stands any hope of understanding what
they mean. Instead the plan is to build up a database mapping "OS type/version"
to "required set of acpi, pic settings". The wizard will then present a way to
select what OS type is being installed & automatically apply the optimial
acpi/pic settings to make it work.
Comment 3 Hugh Brock 2007-05-09 16:04:32 EDT
We have now added the OS type/version interface to the create wizard.

Note You need to log in before you can comment on or make changes to this bug.