Bug 214376 - High-pitched tone coming from speakers
High-pitched tone coming from speakers
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 06:10 EST by An. N
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 07:58:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/root/scsconfig.log (45.38 KB, text/plain)
2006-11-17 03:56 EST, Chris Thomas
no flags Details

  None (edit)
Description An. N 2006-11-07 06:10:11 EST
Description of problem:
A loud background high-pitched tone is emitted by the speakers/headphones when
playing sound. Moreover, often after stopping and resuming playback, the sound
is gone. Frankly I don't even know if it's a bug with alsa.

Version-Release number of selected component (if applicable):
alsa-lib-1.0.12-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Start fedora
2. Play sound from any PCM source
3.
  
Actual results:
Sound is playing, a high-pitched tone is heard simultaneously.

Expected results:
Clear sound

Additional info:
Card: HDA NVidia
Chip: Analog Devices AD1986A

*** LSPCI output
00:00.0 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.1 RAM memory: nVidia Corporation C51 Memory Controller 0 (rev a2)
00:00.2 RAM memory: nVidia Corporation C51 Memory Controller 1 (rev a2)
00:00.3 RAM memory: nVidia Corporation C51 Memory Controller 5 (rev a2)
00:00.4 RAM memory: nVidia Corporation C51 Memory Controller 4 (rev a2)
00:00.5 RAM memory: nVidia Corporation C51 Host Bridge (rev a2)
00:00.6 RAM memory: nVidia Corporation C51 Memory Controller 3 (rev a2)
00:00.7 RAM memory: nVidia Corporation C51 Memory Controller 2 (rev a2)
00:02.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:03.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:04.0 PCI bridge: nVidia Corporation C51 PCI Express Bridge (rev a1)
00:05.0 VGA compatible controller: nVidia Corporation C51PV [GeForce 6150] (rev a2)
00:09.0 RAM memory: nVidia Corporation MCP51 Host Bridge (rev a2)
00:0a.0 ISA bridge: nVidia Corporation MCP51 LPC Bridge (rev a3)
00:0a.1 SMBus: nVidia Corporation MCP51 SMBus (rev a3)
00:0a.2 RAM memory: nVidia Corporation MCP51 Memory Controller 0 (rev a3)
00:0b.0 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0b.1 USB Controller: nVidia Corporation MCP51 USB Controller (rev a3)
00:0d.0 IDE interface: nVidia Corporation MCP51 IDE (rev a1)
00:0e.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM
Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron]
Miscellaneous Control
04:08.0 Ethernet controller: Intel Corporation 82544EI Gigabit Ethernet
Controller (Copper) (rev 02)

*** installed alsa packages
alsa-utils-1.0.12-3.fc6
alsa-lib-1.0.12-2.fc6
alsa-oss-1.0.12-3.fc6
alsa-lib-devel-1.0.12-2.fc6

*** LSMOD output
snd_hda_intel          22613  0 
snd_hda_codec         154049  1 snd_hda_intel
snd_seq_dummy           8133  0 
snd_seq_oss            37057  0 
snd_seq_midi_event     11841  1 snd_seq_oss
snd_seq                57137  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device         12621  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            46561  0 
snd_mixer_oss          20673  1 snd_pcm_oss
snd_pcm                80453  3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer              27077  2 snd_seq,snd_pcm
snd                    57029  9
snd_hda_intel,snd_hda_codec,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore              14113  1 snd
snd_page_alloc         14281  2 snd_hda_intel,snd_pcm
ppdev                  13125  0 
nvidia               4723060  22 
nls_utf8                6337  1 
nfsd                  221169  17 
exportfs               10049  1 nfsd
lockd                  66249  2 nfsd
nfs_acl                 7873  1 nfsd
autofs4                25413  2 
hidp                   24129  2 
rfcomm                 45912  0 
l2cap                  31681  10 hidp,rfcomm
bluetooth              58917  5 hidp,rfcomm,l2cap
sunrpc                158333  12 nfsd,lockd,nfs_acl
freq_table              9793  0 
dm_mirror              32913  0 
dm_mod                 61529  1 dm_mirror
video                  21061  0 
sbs                    20225  0 
i2c_ec                  9281  1 sbs
button                 10961  0 
battery                14405  0 
ac                      9541  0 
ipv6                  267745  14 
parport_pc             31205  1 
lp                     17033  0 
parport                40841  3 ppdev,parport_pc,lp
floppy                 61285  1 
sg                     38493  0 
ide_cd                 42337  3 
forcedeth              46021  0 
k8_edac                18561  0 
e1000                 123473  0 
i2c_nforce2            11457  0 
i2c_core               25537  3 nvidia,i2c_ec,i2c_nforce2
edac_mc                27209  1 k8_edac
pl2303                 24389  0 
usbserial              36393  1 pl2303
pcspkr                  7361  0 
cdrom                  38625  1 ide_cd
serio_raw              11205  0 
sata_nv                15685  3 
libata                102745  1 sata_nv
sd_mod                 24897  24 
scsi_mod              138601  3 sg,libata,sd_mod
ext3                  135369  2 
jbd                    63081  1 ext3
ehci_hcd               35533  0 
ohci_hcd               25181  0 
uhci_hcd               27725  0
Comment 1 Martin Stransky 2006-11-09 10:12:27 EST
Please attach /root/scsconfig.log and check my how-to
(http://people.redhat.com/stransky/alsa/)
Comment 2 An. N 2006-11-10 04:03:26 EST
FYI: The problem was fixed by adding the following line a in a file in
/etc/modprobe.d:

options snd-hda-intel position_fix=1 model=3stack

Unfortunately I don't remember where I found the solution, but it took a
considerable amount of googling. The requested file /root/scsconfig.log does not
exist. /root contains only these files:
scsound.log
scsrun.log
Comment 3 Martin Stransky 2006-11-10 05:38:49 EST
Thanks, I'll check if it's fixed in upstream.
Comment 4 Chris Thomas 2006-11-17 03:56:11 EST
Created attachment 141461 [details]
/root/scsconfig.log

I have the same problem on similar hardware. I have an Asus M2NPV-VM
motherboard. It has the new nvidia 6150 chipset. Attached is
/root/scsconfig.log. I didn't get to try the solution in comment #2 because I
don't really understand it. Should I create a new file in the /etc/modprobe.d
directory with the text or  should I modify a file like /etc/modprobe.conf?
Comment 5 An. N 2006-11-17 07:30:54 EST
Chris: You can create a file named "sound" in the /etc/modprobe.d/ directory and
place the following line in it:

options snd-hda-intel position_fix=1 model=3stack

Upon reboot I had my sound back.
Comment 6 Chris Thomas 2007-01-14 11:58:48 EST
I tried your solution, Andrzej and it worked great. I also can confirm that this
problem if fixed upstream. I deleted the /etc/modprobe.d/sound file and compiled
the alsa 1.0.14rc1 stuff on Martin's website. The new alsa works too. Thanks
both of you for your help.
Comment 7 Martin Stransky 2007-01-15 07:58:24 EST
Okay, Thanks.

Note You need to log in before you can comment on or make changes to this bug.