Bug 214407 - pm-suspend checks support for suspend-to-disk while.. suspending to ram
pm-suspend checks support for suspend-to-disk while.. suspending to ram
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pm-utils (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 215385 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 09:50 EST by Arjan van de Ven
Modified: 2015-03-04 20:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 11:38:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arjan van de Ven 2006-11-07 09:50:33 EST
Description of problem:

the pm-suspend script checks if /sys/power/disk exists, while pm-suspend is for
suspend-to-ram! This is a c&p error, and it won't show up on stock kernels since
those usually support both, but for special cases it does show up (like on my
derived mini distribution)
Comment 1 Till Maas 2006-11-14 15:52:55 EST
*** Bug 215385 has been marked as a duplicate of this bug. ***
Comment 2 Till Maas 2006-11-14 15:54:48 EST
the PAE kernel does not support suspend-to-disk atm, so this bug is relevant for
stock kernel users, too.
Comment 3 Arjan van de Ven 2006-12-13 08:26:53 EST
ping?
Comment 4 Phil Knirsch 2007-01-24 11:38:56 EST
Fix for it will be in next build along with a useful error message in case
someone tries to suspend on a kernel without /sys/power/state or hibernate on a
kernel without the previous and /sys/power/state.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.