Bug 21442 - binaries in /sbin are linked against libraries in /usr/lib and /usr/kerberos/lib
binaries in /sbin are linked against libraries in /usr/lib and /usr/kerberos/lib
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 13:52 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-29 06:20:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-28 13:52:45 EST
There are one or more binaries from this package in /sbin that are linked
against libraries in /usr/lib. I am aware that there is a static version of
restore, but why not just make the default version statically linked, period?

In any case, enough binaries are linked against ncurses and readline, for
example, to perhaps warrant placing those two libs in /lib. Perhaps a cut-
down version of ncurses?

Even better, use termcap, as that's on the root partition anyway, isn't it?
Comment 1 Bill Nottingham 2000-11-28 19:48:27 EST
The samba mount.smbfs binaries in /sbin are symlinks to /usr/sbin,
so I'd say this is technically OK.
It's theoretically possible to links the SSL and kerberos libraries
statically, I suppose.
Comment 2 Need Real Name 2000-11-29 06:20:10 EST
Prefer they were shared, actually ... smaller footprint etc.

Putting the Kerberos libs and SSL in /lib and putting a symlink in /usr/lib looks
like a good compromise ???

I can see why this is awkward, though -- you want the tools to be secure, but
that builds up the complexity and size.

Comment 3 Bill Nottingham 2001-01-18 19:20:55 EST
Since the binaries aren't actually in /sbin (they're only symlinks
for mount's sake), I'm not going to change how they are linked.

Note You need to log in before you can comment on or make changes to this bug.