Bug 21443 - X11 does not allow localhost in /etc/X0.hosts
X11 does not allow localhost in /etc/X0.hosts
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-28 13:54 EST by George Armhold
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-20 19:22:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Armhold 2000-11-28 13:54:39 EST
Listing hosts in /etc/X0.hosts allows these hosts to talk to the X server
running on display 0 without further authorization.  This seems to work for
any host I add to that file except the host the X server is actually
running on.  I tried adding "localhost", "127.0.0.1", "LOCAL", my hostname,
my IP addr and my FQHN.  None of them allow access to processes running on
the X server machine.  This type of access is needed for running Java
Servlets, as the AWT routines need to talk to an X server.
Comment 1 Mike A. Harris 2001-05-20 19:22:50 EDT
How are you initiating these programs? I have no trouble starting programs
on the local host.
Comment 2 Mike A. Harris 2001-07-28 06:44:05 EDT
Closing bug due to lack of response in reasonable amount of time.

Note You need to log in before you can comment on or make changes to this bug.