Bug 214473 - Alt not working
Summary: Alt not working
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-07 19:41 UTC by Sara Khalatbari
Modified: 2018-04-11 07:00 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 14:39:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xev with desktop effects off (14.56 KB, text/plain)
2007-10-25 15:19 UTC, Sara Khalatbari
no flags Details
xev with desktop effects on (24.00 KB, text/plain)
2007-10-25 15:19 UTC, Sara Khalatbari
no flags Details

Description Sara Khalatbari 2006-11-07 19:41:00 UTC
Description of problem:
The Alt key is not working when the desktop effects are on.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Behdad Esfahbod 2006-11-07 21:11:43 UTC
It's worth mentioning that Sara's setup is that she carried her home directory
from her FC5 install.  The problem didn't happen in a newly created account+home.

Comment 2 Sara Khalatbari 2006-11-13 19:17:38 UTC
I reset all the keyboard prefrences back to defaults and removed my Persian
keyboard layouts and the Alt is working perfectly again.

We tried it on two other FC6s and they worked as well.

Comment 3 Matěj Cepl 2007-10-23 21:26:44 UTC
When you re-enable Persian keyboard layout (without changing the defaults), does
it work?

(Sorry, for forgetting about this bug -- I am now cleaning our bugzilla to make
sure this doesn't happen that often in future).

Comment 4 Sara Khalatbari 2007-10-23 21:46:31 UTC
Nope. When I re-enable the persian keyboard, I can't use my alt anymore.
Keyboard short cuts stop working actually. 
like Alt + 1, Alt + 2, does not change the tabs in Firefox.
Or Ctrl + C does not copy anymore.

Comment 5 Matěj Cepl 2007-10-24 07:10:31 UTC
And just to be sure, that I understand correctly -- when you switch Desktop
Effects off, everything works as expected?

Could you attach to this document output of xev (run xev >xev-out.txt 2>&1,
press Alt, Win-key, Alt+C, Ctrl-C, etc., kill xev with your mouse, and then
attach to this bug uncompressed file xev-out.txt), please?

Comment 6 Kristian Høgsberg 2007-10-24 18:54:41 UTC
One workaround that might work is to say

  gconftool-2 --recursive-unset /apps/compiz

Comment 7 Sara Khalatbari 2007-10-25 15:19:34 UTC
Created attachment 237461 [details]
xev with desktop effects off

Comment 8 Sara Khalatbari 2007-10-25 15:19:58 UTC
Created attachment 237471 [details]
xev with desktop effects on

Comment 9 Matěj Cepl 2007-12-10 09:22:54 UTC
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]

Comment 10 Matěj Cepl 2008-01-15 14:39:54 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional
information.

Closing as INSUFFICIENT_DATA.

{This is mass-closing of all obsolete bugs; if this bug was in your opinion
closed by mistake, please, reopen it with additional information; thanks a lot
and I am sorry for bothering you in such case.}

Comment 11 Behdad Esfahbod 2008-01-15 19:39:05 UTC
I believe this is fixed in F8.


Note You need to log in before you can comment on or make changes to this bug.