Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 214487 - "Attempt to mark a already marked region" messages when creating new cmirrors
"Attempt to mark a already marked region" messages when creating new cmirrors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Retired
Component: cmirror (Show other bugs)
4
All Linux
high Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 15:27 EST by Corey Marthaler
Modified: 2010-01-11 21:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-05 17:38:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2006-11-07 15:27:38 EST
Description of problem:

I created a cmirror put a gfs filesystem on it, mounted it, and then started I/O
to that fs from all 4 nodes in the cluster. After that, I created 3 new cmirrors
and each time, I saw messages similar to these on the mirror server for the 1st
mirror only.

[...]
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84591)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84590)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84589)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84588)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84587)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84586)
Nov  7 09:35:19 link-04 kernel: dm-cmirror: Attempt to mark a already marked
region (4,84585)
[...]


[root@link-04 ~]# lvs -a -o +devices
  LV                 VG    Attr   LSize   Origin Snap%  Move Log          Copy%
 Devices
  mirror             corey mwi-ao  50.00G                    mirror_mlog  100.00
mirror_mimage_0(0),mirror_mimage_1(0)
  mirror2            corey mwi-a-  50.00G                    mirror2_mlog  10.29
mirror2_mimage_0(0),mirror2_mimage_1(0)
  [mirror2_mimage_0] corey iwi-ao  50.00G                                      
 /dev/sdc1(0)
  [mirror2_mimage_1] corey iwi-ao  50.00G                                      
 /dev/sdd1(0)
  [mirror2_mlog]     corey lwi-ao   4.00M                                      
 /dev/sdb1(12800)
  mirror3            corey mwi-a-  52.00M                    mirror3_mlog 100.00
mirror3_mimage_0(0),mirror3_mimage_1(0)
  [mirror3_mimage_0] corey iwi-ao  52.00M                                      
 /dev/sde1(0)
  [mirror3_mimage_1] corey iwi-ao  52.00M                                      
 /dev/sdf1(0)
  [mirror3_mlog]     corey lwi-ao   4.00M                                      
 /dev/sdb1(12801)
  mirror4            corey mwi-a- 100.00G                    mirror4_mlog   3.15
mirror4_mimage_0(0),mirror4_mimage_1(0)
  [mirror4_mimage_0] corey iwi-ao 100.00G                                      
 /dev/sdg1(1)
  [mirror4_mimage_1] corey iwi-ao 100.00G                                      
 /dev/sde1(13)
  [mirror4_mlog]     corey lwi-ao   4.00M                                      
 /dev/sdb1(12802)
  [mirror_mimage_0]  corey iwi-ao  50.00G                                      
 /dev/sda1(0)
  [mirror_mimage_1]  corey iwi-ao  50.00G                                      
 /dev/sdb1(0)
  [mirror_mlog]      corey lwi-ao   4.00M                                      
 /dev/sdg1(0)
[root@link-04 ~]# dmsetup ls
corey-mirror4   (253, 17)
corey-mirror4_mimage_1  (253, 16)
corey-mirror2_mlog      (253, 6)
corey-mirror3   (253, 13)
corey-mirror4_mimage_0  (253, 15)
corey-mirror3_mimage_1  (253, 12)
corey-mirror    (253, 5)
corey-mirror2   (253, 9)
corey-mirror3_mimage_0  (253, 11)
corey-mirror3_mlog      (253, 10)
corey-mirror2_mimage_1  (253, 8)
corey-mirror2_mimage_0  (253, 7)
corey-mirror4_mlog      (253, 14)
corey-mirror_mimage_1   (253, 4)
corey-mirror_mimage_0   (253, 3)
VolGroup00-LogVol01     (253, 1)
VolGroup00-LogVol00     (253, 0)
corey-mirror_mlog       (253, 2)


Version-Release number of selected component (if applicable):
[root@link-04 ~]# rpm -qa | grep lvm
lvm2-cluster-2.02.13-1
lvm2-cluster-debuginfo-2.02.06-7.0.RHEL4
lvm2-2.02.13-1
[root@link-04 ~]# rpm -qa | grep cmirror
cmirror-kernel-debuginfo-2.6.9-13.0
cmirror-kernel-smp-2.6.9-15.5
cmirror-kernel-largesmp-2.6.9-13.0
cmirror-kernel-2.6.9-13.0
cmirror-1.0.1-0
cmirror-debuginfo-1.0.1-0
Comment 1 Jonathan Earl Brassow 2006-12-05 10:11:05 EST
When one log server would move (due to failure or deactivation of the mirror on
the server), the clients would send their marked region lists for all their
mirrors to their respective servers.  Since some of the servers did not move, it
would result in those servers reporting that the regions where already marked.

The fix was to pass over those regions in the marked region list that did not
correspond to the log whose server had moved.

Additionally, the clear region list would be emptied of its contents - rather
than just those regions associated with the log that moved.  This too would
cause the "already marked" messages to appear (except this time, when the next
mark on those regions would occur).

I don't believe the messages where anything more than an annoyance.
Comment 2 Corey Marthaler 2006-12-18 18:55:53 EST
Is the fix for this in lvm2-2.02.17-1/lvm2-cluster-2.02.17-1? I'm still seeing
these in the latest build.
Comment 3 Jonathan Earl Brassow 2006-12-19 11:57:43 EST
You'll have to wait for a new cmirror-kernel package.
Comment 4 Corey Marthaler 2007-03-19 18:57:52 EDT
Haven't seen this since getting new builds, time to mark verified.
Comment 5 Chris Feist 2008-08-05 17:38:54 EDT
Fixed in current release (4.7).

Note You need to log in before you can comment on or make changes to this bug.