Bug 214528 - [In sol] Some solitaire rules produce an error, can't get help on any of them
[In sol] Some solitaire rules produce an error, can't get help on any of them
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-games (Show other bugs)
6
x86_64 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 18:41 EST by Vladimir Mosgalin
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.16.3-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 15:28:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Mosgalin 2006-11-07 18:41:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Description of problem:
In "sol" from gnome-games (also called "AisleRiot 2.16.0"), an error pops up when selecting some of the rules when using ru_RU.UTF-8 or other non-english locale. Also help on rules doesn't work when name of the game is translated.

Version-Release number of selected component (if applicable):
gnome-games-2.16.0-1.fc6.x86_64

How reproducible:
Always


Steps to Reproduce:
Bug 1:
1. Run sol in ru_RU.UTF-8 locale.
2. Open rules chooser: "Игра" -> "Выбор игры"
3. Select "Афина", "Десять поперек" or "Клондайк" (also happens with a few others, not with all though).

Bug 2:
1. Select any rules (still in ru_RU.UTF-8)
2. Select rules help: "Справка" -> (name of the rules)

Actual Results:
Bug 1: An error pops up, saying something about "error while saving/loading configuration information for aisleriot", without any additional information.

Bug 2: "can't open section" error pops up and empty help window opens.

Expected Results:
1: No error

2: Correct page with (usually unlocalized) rules description

Additional info:
This isn't unique to ru_RU.UTF-8 locale, I tried a few others, for example ja_JP.eucJP. I guess it happens for every locale where rules names are localized, i.e. virtually any except for French (French help is the only localized one).

This bug is new. It has been some time since I ran sol, but I remember that a few years ago it worked correctly. Maybe it's broken since gnome-games 2.16 or 2.14.
Comment 1 Andreas Røsdal 2006-12-28 16:16:02 EST
This bug has been fixed in gnome-games 2.16.2.

http://bugzilla.gnome.org/show_bug.cgi?id=359365
Comment 2 Hans de Goede 2007-07-18 15:28:25 EDT
(In reply to comment #1)
> This bug has been fixed in gnome-games 2.16.2.
> 
> http://bugzilla.gnome.org/show_bug.cgi?id=359365

Thanks for reporting this, gnome-games-2.16.3 is now available as an update for
FC-6, closing.

Note You need to log in before you can comment on or make changes to this bug.