Bug 214550 - /var/log/messages shows failed to load kdump kernel after installation
/var/log/messages shows failed to load kdump kernel after installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jarod Wilson
Brian Brock
:
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-11-08 00:36 EST by Giribabu Bikki
Modified: 2014-05-19 05:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: kexec-tools-1.101-155.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 10:46:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hardware deatils (3.81 KB, application/octet-stream)
2006-11-14 08:04 EST, Giribabu Bikki
no flags Details
output of /proc/iomem (1.48 KB, text/plain)
2006-12-22 05:43 EST, Giribabu Bikki
no flags Details

  None (edit)
Description Giribabu Bikki 2006-11-08 00:36:32 EST
Description of problem:/var/log/messages shows failed to load kdump kernel after
installation


Version-Release number of selected component (if applicable): RHEL5-b1 weekly
release 01 Nov 2006


How reproducible:


Steps to Reproduce:
1.install RHEL5 Beta1 weekly update 01 Nov 06
2.cat /var/log/messages|grep fail
3.The error shown is kdump: kexec: failed to load kdump kernel
  kump: failed to startup  
  
Actual results:kdump: kexec: failed to load kdump kernel
               kump: failed to startup  

Expected results:no errors or fails



Additional info:
Comment 1 Linda Wang 2006-11-13 11:38:52 EST
Can you provide more information on 
1) HW type that you saw the problem on
2) The exact version of the kernel that the kexec/kdump failed message
3) can you give RHEL5 latest snapshoot a try? 
Comment 2 Giribabu Bikki 2006-11-14 08:04:05 EST
Created attachment 141148 [details]
hardware deatils
Comment 3 Amit Bhutani 2006-11-16 09:45:30 EST
Attachment from comment #2 should satisfy the NEEDINFO.
Comment 4 Linda Wang 2006-12-01 10:54:04 EST
03:02.0 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)
03:02.1 SCSI storage controller: Adaptec AHA-3960D / AIC-7899A U160/m (rev 01)

on 

2 Intel(R) Pentium(R) 4 CPU 2.80GHz

with 1G memory
Comment 5 Jarod Wilson 2006-12-01 11:00:17 EST
The problem here is that we install kexec-tools with the kdump initscript
chkconfig'd on. In the case of a clean install, the user generally hasn't
configured kdump yet. Given that we have the kdump firstboot module and
system-config-kdump now, I'd say we flip the kdump script back to not being on
by default, as both tools will take the necessary steps to turn it on, once its
actually been configured (i.e., kernel boot params are set up to reserve kdump mem).
Comment 6 Jarod Wilson 2006-12-01 16:12:50 EST
Per discussion w/nhorman, we'll set the kdump script to not be chkconfig'd on by
default, and let the user enable it, be that manually, via the firstboot module
or system-config-kdump. Fix will show up in build -140.el5.
Comment 7 Amit Bhutani 2006-12-13 10:31:37 EST
From comment #6:
> Fix will show up in build -140.el5.

Sorry. I'm not clear which package are we talking about here?? This doesn't
match either the initscripts or the system-config-kdump package versions.
Comment 8 Jarod Wilson 2006-12-13 10:38:09 EST
Sorry, that'd be kexec-tools-1.101-140.el5 (or later) that carries the fix. (The
kdump initscript is part of the kexec-tools package).
Comment 9 Giribabu Bikki 2006-12-15 08:25:17 EST
I regressed with kexec-tools-1.101-140.el5.x86_64 &
kexec-tools-debuginfo-1.101-140.el5.x86_64 though it says kdump is operational,
it again gave me the failed message says kexec: failed to load kdump kernel
                                      kump: failed to start up
and no vmlinux file is getting created.  
Comment 10 Jarod Wilson 2006-12-15 09:49:25 EST
Can you clarify exactly what you're doing that is failing? Is this immediately
following a clean install? The only change here is to not chkconfig kdump on by
default, so that after a clean install, it doesn't try to start the first time
the machine boots. Instead, you get the firstboot kdump config tool, which if
you decide to configure kdump, will chkconfig kdump on, and reboot your machine,
after which kdump should successfully start up.
Comment 11 Giribabu Bikki 2006-12-20 07:39:54 EST
I tried with RHEL5 B2 snapshot-3 where the kexec is kexec-tools-1.101-143.el5.
It gives me the same error. this is failing even after "chkconfig kdump on" on
every reboot. manual starting of service kdump start also failing
Comment 12 Jarod Wilson 2006-12-20 10:37:40 EST
What do 'cat /proc/cmdline' and 'cat /proc/iomem' spit out? It sounds like crash
kernel memory hasn't been reserved.
Comment 13 Giribabu Bikki 2006-12-22 05:42:05 EST
I seen this issue only on some systems like PE1850, PE6600 though I have 2GB of
RAM on these systems. On some other systems kdump is working fine.
the output of /proc/cmdline shows:
ro root=/dev/VolGroup00/LogVol00 rhgb quiet
Comment 14 Giribabu Bikki 2006-12-22 05:43:47 EST
Created attachment 144267 [details]
output of /proc/iomem
Comment 15 Jarod Wilson 2006-12-22 10:16:20 EST
Okay, looks like you're getting errors logged because there isn't any memory
being reserved for kdump. Your command line shows nothing along the lines of
"crashkernel=128M@16M" and /proc/iomem doesn't show a reserved crash kernel
region (should see something along the lines of "01000000-08ffffff : Crash
kernel" in /proc/iomem).

Installing kexec-tools doesn't automatically configure the crashkernel
reservation, that part has to be done manually. Please try adding
"crashkernel=128M@16M" to your kernel commmand line, either by editing grub.conf
directly or via system-config-kdump, restart your system and see if that doesn't
resolve the issue.
Comment 16 Giribabu Bikki 2006-12-29 01:44:15 EST
yes, it resolved the issue. now I am able to see crash kernel entry in
/proc/iomem. This issue is fixed   
Comment 17 Jarod Wilson 2007-01-02 10:46:42 EST
Closing, based on comment #16.
Comment 18 pengcz 2010-05-19 20:44:10 EDT
(In reply to comment #17)
> Closing, based on comment #16.    

hi,all
   now, I got the same message as  Giribabu Bikki described above, the following are my configures:
1. /boot/grub/menu.lst
title Fedora (2.6.33.1)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.33.1 ro root=UUID=2cab961e-aa22-447e-a574-fdfe4dea6754  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb crashkernel=128M@16M
        initrd /boot/initrd-2.6.33.1.img
2.when I compiled linux-2.6.33.1, the configures related to kexec and kdump are:
CONFIG_SYSFS=y
CONFIG_PROC_VMCORE=y
CONFIG_KEXEC=y
CONFIG_DEBUG_INFO=y
CONFIG_CRASH_DUMP=y
CONFIG_HIGHMEM4G=y
 CONFIG_SMP=n 
CONFIG_PHYSICAL_START=0x1000000
 CONFIG_RELOCATABLE=y 

but my /proc/cmdline is "ro root=UUID=2cab961e-aa22-447e-a574-fdfe4dea6754  LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb crashkernel=128M@16M",
Comment 19 pengcz 2010-05-19 21:09:59 EDT
hi,all
   I am so sorry for sending the last mail!

   now, I got the same message as  Giribabu Bikki described above,and
   as follows:

May 20 08:59:20 localhost kdump: No crashkernel parameter specified for running kernel
May 20 08:59:20 localhost kdump: failed to start up

 the followings are information about kexec and kdump:
1. kexec-tools-2.0.0-32.fc12.i686

2. Intel(R) Core(TM)2 Duo CPU     E7400  @ 2.80GHz
   with 2G memory

3. /boot/grub/menu.lst
title Fedora (2.6.33.1)
        root (hd0,0)
        kernel /boot/vmlinuz-2.6.33.1 ro
root=UUID=2cab961e-aa22-447e-a574-fdfe4dea6754  LANG=en_US.UTF-8
SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb crashkernel=128M@16M
        initrd /boot/initrd-2.6.33.1.img

4. when I compiled linux-2.6.33.1, the configures related to kexec and kdump
are:
CONFIG_SYSFS=y
CONFIG_PROC_VMCORE=y
CONFIG_KEXEC=y
CONFIG_DEBUG_INFO=y
CONFIG_CRASH_DUMP=y
CONFIG_HIGHMEM4G=y
 CONFIG_SMP=n 
CONFIG_PHYSICAL_START=0x1000000
 CONFIG_RELOCATABLE=y 

5. my /proc/cmdline is "ro root=UUID=2cab961e-aa22-447e-a574-fdfe4dea6754 
LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb
crashkernel=128M@16M"

6. there is no "crash kernel" in /proc/iomem

7. before restarting,I executed the command "chkconfig kdump on"

based on the following message, for resolving this question, what
should I do? any advice will be appreciated!

Best regards
pengcz
Comment 20 Baoquan He 2014-05-19 05:31:27 EDT
Hi,

Did you check /sys/kernel/kexec_crash_size? I think it's because the crashkernel reservation failed because you specified the position of crashkernel memory reserved.  Here it's 16M, if reserving crashkernel memory at 16M failed, it will happen like what you are seeing. 

So could you just set crashkernel=128M in /boot/grub/menu.lst, and try it again.

Thanks
Baoquan

Note You need to log in before you can comment on or make changes to this bug.