Bug 214735 - mount.cifs fails to allow ls of large directory on samba share
Summary: mount.cifs fails to allow ls of large directory on samba share
Status: CLOSED DUPLICATE of bug 212123
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-09 03:35 UTC by Jeff Hetrick
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-18 12:47:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Hetrick 2006-11-09 03:35:17 UTC
Description of problem: I run a samba server on my FC5 box that servers files
for my other linux and windows machines.  When on FC6, I mount the shares using
the command:
//192.168.0.xx/share /mnt/server  cifs 
rw,user=myname,password=mypassword,noauto,suid,users  0 0

It appears that the mount.cifs does not work properly.  When I mount a user
share and cp a large directory over to the file server, I can't ls the
directory.  I get the error:  "ls: reading directory .: Invalid argument" after
sucessfully cd to the said directory.  I can't ls the directory from outside of
it either.

However, when I log-in to the same server and access the same directory with my
Win2k box, all files view fine!  I am assuming the bug is in the mount.cifs
command and I have not compiled smbfs into the kernel so I can't attempt that.

My FC6 system is fully updated as of today.
Version-Release number of selected component (if applicable):
samba-client-3.0.23c-2 seems to have mount.cifs included


How reproducible:  Every time I cp a large directory to a mounted samba share
using the above syntax to mount and specifing -t CIFS.  Occurs both when mounted
maually and also when calling mount from fstab.


Steps to Reproduce:
1.  mount a samba share using -t CIFS
2.  cp a large directory over to the mounted share
3.  cd to that mounted directory and attempt to ls the directory
  
Actual results:
ls: reading directory .: Invalid argument

Expected results:
The directory to ls or ls -l like any other directory would.

Additional info:

Comment 1 Jeff Hetrick 2006-11-09 03:46:09 UTC
One added bit of information that I left out.  I can view smaller
sub-directories on the same share, it only chokes on the large sub-directories
and that is why I described cp of a large directory.  I believe it is a
sub-directory of approx. 800mb or so the first time I found this problem.

Comment 2 Roderick Derks 2006-11-09 07:20:25 UTC
I have exactly the same problem.

Comment 3 Jan ONDREJ 2006-11-09 12:52:48 UTC
Same problem to read some directory content for mounted Fedora mirror directory.

[ondrejj@work ~]$ ls /home/ftp/pub/linux/fedora/linux/core/updates/6/i386
ls: reading directory /home/ftp/pub/linux/fedora/linux/core/updates/6/i386:
Invalid argument
[ondrejj@work ~]$ ls /home/ftp/pub/linux/fedora/linux/core/updates/6/i386/repodata/
filelists.xml.gz  other.xml.gz  primary.xml.gz  repomd.xml  updateinfo.xml.gz
[ondrejj@work ~]$ 

If I know directory name, I can list it, but ls does not show its name. :)

Comment 4 Jay Fenlason 2006-11-09 13:21:17 UTC
This is a kernel bug.  I'm redirecting it to the right component. 

Comment 5 Jan ONDREJ 2006-11-09 16:54:43 UTC
I think it is a duplicate of bug #212123.

Comment 6 Steve French 2006-11-25 20:36:28 UTC
Yes - it is fixed and is a duplicate of 212123 although that was not the
original bug #.

It should be returned.

Comment 7 kennyams 2007-06-07 16:46:13 UTC
I have this problem when accessing a dlink dns323 home file file server
I do not get the problem using smbfs on ubuntu.
I am using fc6 and always keep up to date.
My mount command is.
//192.168.1.2/Volume_1/pictures         /mnt/dns323/pictures    cifs   
user=ken,password=xxxxxx,uid=ken,gid=users

I can supply an ethereal trace if that would be helpful.
If I ls the directory I can see all the names of the files in the trace but get
the following error.

ls: reading directory /mnt/dns323/pictures/Lumix/Holidays/italy/2006/: Invalid
argument

Comment 8 kennyams 2007-06-21 16:37:23 UTC
Please disregard my last comment all is working fine
I had an old kernel hacked in.

Comment 9 Jeff Layton 2007-11-18 12:47:23 UTC

*** This bug has been marked as a duplicate of 212123 ***


Note You need to log in before you can comment on or make changes to this bug.