Bug 214741 - VM cannot start with the XML file, which was dumped by "virsh dumpxml".
VM cannot start with the XML file, which was dumped by "virsh dumpxml".
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 23:33 EST by mizushima.kazuk@jp.fujitsu.com
Modified: 2010-10-22 02:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:19:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The XML file I used (882 bytes, text/xml)
2006-11-08 23:33 EST, mizushima.kazuk@jp.fujitsu.com
no flags Details
patch to drop the kernel information when creating a xen domain with bootloader (2.97 KB, patch)
2006-11-27 17:20 EST, Daniel Veillard
no flags Details | Diff

  None (edit)
Description mizushima.kazuk@jp.fujitsu.com 2006-11-08 23:33:12 EST
Description of problem:
 The error occured after the command "virsh create" is executed by the XML 
which dumped from Virtual System made by "Para-Virtualized", and Virtual 
System didn't start.

 Error information
 # virsh create /tmp/dump_Para_FC6.xml
 libvir: Xen Daemon error : POST operation failed: (xend.err 'Error creating 
domain: Kernel image does not exist: /var/lib/xen/vmlinuz.FMDJma')
 Failed to create domain Para_FC6
 error: Failed to create domain from /tmp/dump_Para_FC6.xml

Version-Release number of selected component (if applicable):
 libvirt-0.1.7-2.src.rpm
  Version     : 0.1.7
  Release     : 2

How reproducible:
 everytime

Steps to Reproduce:
 1.Start domain
   #xm create /etc/xen/Para_FC6
 2.Dump xml
   #virsh dumpxml Para_FC6 > /tmp/dump_Para_FC6.xml
 3.Stop domain
   #virsh shutdown Para_FC6
 4.Start domain
   #virsh create /tmp/dump_Para_FC6.xml

Actual results:
 Virtual System didn't start after creating a VM based on the XML 
file which dumped from Virtual System made by "Para-Virtualized".

Expected results:
 Virtual System can start with XML file, which dumped from a running 
Virtual system by "dumpxml" command.

Additional info:
 The XML file "dump_Para_FC6.xml" which I used is attached.
Comment 1 mizushima.kazuk@jp.fujitsu.com 2006-11-08 23:33:13 EST
Created attachment 140747 [details]
The XML file I used
Comment 2 Daniel Veillard 2006-11-27 17:18:46 EST
I have a patch for this issue that I plan to push upstream. Basically when
creating a domain, if there is a pygrub bootloader, then the whole <os>
section should be ignored when passing the informations to xend.
The patch below was tested successfully,

Daniel
Comment 3 Daniel Veillard 2006-11-27 17:20:34 EST
Created attachment 142233 [details]
patch to drop the kernel information when creating a xen domain with bootloader
Comment 4 Daniel Veillard 2006-11-27 17:24:24 EST
Commited in libvirt upstream,

Daniel
Comment 5 RHEL Product and Program Management 2006-11-27 21:50:33 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 RHEL Product and Program Management 2006-11-27 21:50:51 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 mizushima.kazuk@jp.fujitsu.com 2006-11-28 04:34:19 EST
In this patch, in case of pygrub bootloader, it seems that the
virDomainParseXMLGraphicsDesc function is not called for pygrub.
If it is true, is there any influence that graphic console of paraVM
cannot be connected because the SXP conversion for <graphics> tag will
not be done.
Comment 8 Daniel Veillard 2006-11-28 04:50:41 EST
w.r.t. comment #7, exact but as soon as there is an (image ...) block
then the (bootloader ...) information is ignored by xend. Since the
SXP conversion for <graphics> tag is expected to occur within the 
(image ...) block as in

    (image
        (linux
            (ramdisk /var/lib/xen/initrd.zRAFzd)
            (kernel /var/lib/xen/vmlinuz.pMML_l)
            (args 'ro root=/dev/VolGroup00/LogVol00 rhgb quiet')
            (vncunused 1)
            (vnc 1)
            (display localhost:10.0)
            (xauthority /root/.Xauthority)
        )
    )


 I don't see a solution.

Daniel
Comment 9 Daniel Berrange 2006-11-28 06:52:23 EST
The problem described in comment #7 is already being tracked in a separate ticket
bug 211909 for the libvirt part of the fix, and bug 211928 for the XenD part. So
lets keep discussion in this ticket to be just about the fixing of
bootloader/kernel arg prioritization.
Comment 10 Jay Turner 2006-12-06 22:45:38 EST
QE ack for RHEL5.
Comment 11 Daniel Veillard 2006-12-07 06:37:08 EST
Okay libvirt-0.1.8-6.el5 has been built with the fix. As pointed out in #8 and #9
the point raised in #7 is a separate issue and not covered by this update.

Daniel
Comment 14 RHEL Product and Program Management 2006-12-22 21:19:15 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.