Bug 214758 - MediaWiki installation does not work with not EN locale
MediaWiki installation does not work with not EN locale
Status: CLOSED DUPLICATE of bug 212600
Product: Fedora
Classification: Fedora
Component: mediawiki (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 06:32 EST by Vitaliy S
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-23 11:35:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitaliy S 2006-11-09 06:32:06 EST
Description of problem: MediaWiki installation does not work

Version-Release number of selected component (if applicable): 5.fc6

How reproducible: Try to install mediawiki with non EN locale (e.g. Fr or RU)

Steps to Reproduce:
1. yum install mediawiki httpd mysql-server mysql
2. /sbin/service httpd start
3. /sbin/service mysqld start
4. firefox http://localhost/mediawiki/config/
5. Fill required fields and press install mediawiki
6. Change Locale to Not EN (e.g. FR or RU)
7. Press install mediawiki
Actual results:
installation stops at
Generating configuration file...
Set $wgShowExceptionDetails = true; in LocalSettings.php to show detailed
debugging information.

Expected results:
Installation successful! Move the config/LocalSettings.php file into the parent
directory, then follow this link to your wiki.
Comment 1 Axel Thimm 2006-11-09 15:01:21 EST
Does it work in english locale? Could you provide the debugging info as
requested above? Thanks!
Comment 2 Vitaliy S 2006-11-10 04:08:35 EST
Yes, it works in English locale.

I could not provide the debugging info because existing file LocateSettings.php
does not exist (the installation process creates it in case of success).
Comment 3 Renat 2006-11-14 10:17:25 EST
German locale doesn't work neither
Comment 4 Vitaliy S 2006-11-17 09:16:29 EST
I found the solution.
mediawiki package does not contain serialized and languages folders.

I copied these folders from mediawiki 1.8.2 tarball and after managed to
complete installation.

Comment 5 Axel Thimm 2006-11-23 11:35:01 EST

*** This bug has been marked as a duplicate of 212600 ***

Note You need to log in before you can comment on or make changes to this bug.