Bug 214773 - Impress crash (a11y enabled)
Impress crash (a11y enabled)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 08:14 EST by Michal Babej
Modified: 2013-07-31 19:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.4-5.5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 03:26:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
OOfice's crash report (7.70 KB, text/plain)
2006-11-09 08:14 EST, Michal Babej
no flags Details
gdb backtrace of crash (17.49 KB, text/plain)
2006-11-09 08:35 EST, Michal Babej
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 61812 None None None Never

  None (edit)
Description Michal Babej 2006-11-09 08:14:44 EST
Description of problem:
Impress crashes on editing slides of presentation. The presentation can be
downloaded here: http://ometer.com/OSCON2004.sxi Usually after one-two
Copy&paste or Cut&Paste of text between slides it crashes. I'm running GNOME
with accessibility enabled.

Version-Release number of selected component (if applicable):
openoffice.org-core-2.0.4-5.3
openoffice.org-langpack-sk_SK-2.0.4-5.3
openoffice.org-impress-2.0.4-5.3
openoffice.org-draw-2.0.4-5.3
openoffice.org-math-2.0.4-5.3
openoffice.org-graphicfilter-2.0.4-5.3
openoffice.org-calc-2.0.4-5.3
openoffice.org-xsltfilter-2.0.4-5.3
openoffice.org-writer-2.0.4-5.3
openoffice.org-debuginfo-2.0.4-5.3
gnome-vfs2-2.16.0-4.fc6
gnome-desktop-2.16.0-1.fc6

Actual results:
SIGSEGV

Additional info:
i have included a crash report OOfice generates, and also a gdb backtrace of the
crash (its not the same crash though, but hopefully will help.)

Also seems to be related to upstream bug 61812 (though its closed)
Comment 1 Michal Babej 2006-11-09 08:14:44 EST
Created attachment 140763 [details]
OOfice's crash report
Comment 3 Michal Babej 2006-11-09 08:35:01 EST
Created attachment 140765 [details]
gdb backtrace of crash
Comment 4 Caolan McNamara 2006-11-09 08:56:03 EST
Indeed, same as reported upstream ages ago, but upstream never thought to enable
a11y before dismissing the bug as distro-builder crack.
Comment 5 Caolan McNamara 2006-11-09 10:09:19 EST
adding a workaround, will be in next fc-6 update

Note You need to log in before you can comment on or make changes to this bug.