Bug 214784 - xauth leaves lock files after switching user id
xauth leaves lock files after switching user id
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xauth (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 09:33 EST by Vadym Chepkov
Modified: 2014-06-18 05:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 08:54:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2006-11-09 09:33:15 EST
Description of problem:

xauth lock files are remaining in user home after switching user id.

Version-Release number of selected component (if applicable):
xorg-x11-xauth-1.0.1-2.1
pam-0.99.6.2-3.fc6

How reproducible:

All the time

Steps to Reproduce:
1. Login through ssh as regular user with X11 forwarding enable
2. su - root
3. env|grep XAUTHORITY - points to a random file
4. logout - $XAUTHORITY file won't get deleted
Comment 1 Matěj Cepl 2007-12-10 04:24:08 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Xorg or
Gecko. If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 2 Vadym Chepkov 2007-12-10 06:48:41 EST
The issue doesn't exist in Fedora 8

Note You need to log in before you can comment on or make changes to this bug.