Bug 214798 - microcode size check prevents newer microcode from loading
microcode size check prevents newer microcode from loading
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Geoff Gustafson
Brian Brock
:
: 217956 (view as bug list)
Depends On:
Blocks: 214807
  Show dependency treegraph
 
Reported: 2006-11-09 10:45 EST by Geoff Gustafson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:21:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RHEL5 version of patch to remove microcode size check (1.29 KB, application/octet-stream)
2006-11-09 10:45 EST, Geoff Gustafson
no flags Details

  None (edit)
Description Geoff Gustafson 2006-11-09 10:45:01 EST
Description of problem:
There are a couple size checks in the kernel that require an Intel microcode
package to be at least a default size. A recent microcode update (1.15) is a
smaller size, so this check prevents it from loading.

The patch is upstream here:
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=bd8e39f9e4c0960541c8c69e1f7cb321574d7c90


Version of patch for RHEL5 attached.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2745.el5

How reproducible:
100%

Steps to Reproduce:
1. Install microcode_ctl-1.15 package
2. Try to load microcode "service microcode_ctl start"
3. It fails to load, but works with larger 1.13 package
Comment 1 Geoff Gustafson 2006-11-09 10:45:01 EST
Created attachment 140785 [details]
RHEL5 version of patch to remove microcode size check
Comment 2 Geoff Gustafson 2006-11-09 11:01:53 EST
Without this patch, the updated microcode in 209455 can't be loaded so I'm
setting this as a blocker for that one.
Comment 3 Geoff Gustafson 2006-11-09 11:05:20 EST
Hmm, removing block because that bug was really about microcode_ctl being
started by default, not about updating the data file.
Comment 5 Linda Wang 2006-11-17 11:41:00 EST
patch posted on 11/09/06
Comment 6 RHEL Product and Program Management 2006-11-17 11:44:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 Jay Turner 2006-11-20 14:43:59 EST
QE ack for RHEL5.  It does seem that we're losing some sanity checking there, as
I suspect there's still some "minimal" size, but I'm OK with ripping out the
bounds checking.
Comment 8 Linda Wang 2006-11-30 16:39:11 EST
*** Bug 217956 has been marked as a duplicate of this bug. ***
Comment 9 Don Zickus 2006-12-21 15:24:25 EST
in 2.6.18-1.2789.el5
Comment 10 RHEL Product and Program Management 2006-12-22 21:21:57 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.