Bug 214821 - tomcat web interface not available
Summary: tomcat web interface not available
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat5   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Devrim GUNDUZ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-09 17:10 UTC by Thilo Pfennig
Modified: 2008-01-05 13:19 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 13:19:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thilo Pfennig 2006-11-09 17:10:21 UTC
Description of problem:

I can not access the tomcat web interface

Version-Release number of selected component (if applicable):

tomcat5-5.5.17-6jpp.2


How reproducible:

always

Steps to Reproduce:
1. install and start tomcat5
2. open http://127.0.0.1:8080 in browser (btw; localhost:8080 is not accessible)

  
Actual results:

 1. empty page
 2. errors in log /var/log/tomcat5.catalina.out

Additional info:
9. Nov 06 17:56:11 org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
9. Nov 06 17:56:12 org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
9. Nov 06 17:56:12 org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/81  config=null
9. Nov 06 17:56:12 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
9. Nov 06 17:56:12 org.apache.catalina.startup.Catalina start
INFO: Server startup in 1574 ms
9. Nov 06 18:02:50 org.apache.catalina.core.StandardServer await
WARNING: StandardServer.await: Invalid command 'GET / HTTP/1.1' received
9. Nov 06 18:02:50 org.apache.catalina.core.StandardServer await
WARNING: StandardServer.await: Invalid command 'GET /favicon.ico HTTP/1.1' received
9. Nov 06 18:02:54 org.apache.jk.common.MsgAjp processHeader
SEVERE: BAD packet signature 18245
9. Nov 06 18:02:54 org.apache.jk.common.ChannelSocket processConnection
SEVERE: Error, processing connection
java.lang.IndexOutOfBoundsException
   at java.io.BufferedInputStream.read(libgcj.so.7rh)
   at org.apache.jk.common.ChannelSocket.read(tomcat-ajp-5.5.17.jar.so)
   at org.apache.jk.common.ChannelSocket.receive(tomcat-ajp-5.5.17.jar.so)
   at org.apache.jk.common.ChannelSocket.processConnection(tomcat-ajp-5.5.17.jar.so)
   at
org.apache.jk.common.ChannelSocket$SocketConnection.runIt(tomcat-ajp-5.5.17.jar.so)
   at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(tomcat-util-5.5.17.jar.so)
   at java.lang.Thread.run(libgcj.so.7rh)
9. Nov 06 18:02:55 org.apache.jk.common.MsgAjp processHeader
SEVERE: BAD packet signature 18245
9. Nov 06 18:02:55 org.apache.jk.common.ChannelSocket processConnection
SEVERE: Error, processing connection
java.lang.IndexOutOfBoundsException
   at java.io.BufferedInputStream.read(libgcj.so.7rh)
   at org.apache.jk.common.ChannelSocket.read(tomcat-ajp-5.5.17.jar.so)
   at org.apache.jk.common.ChannelSocket.receive(tomcat-ajp-5.5.17.jar.so)
   at org.apache.jk.common.ChannelSocket.processConnection(tomcat-ajp-5.5.17.jar.so)
   at
org.apache.jk.common.ChannelSocket$SocketConnection.runIt(tomcat-ajp-5.5.17.jar.so)
   at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(tomcat-util-5.5.17.jar.so)
   at java.lang.Thread.run(libgcj.so.7rh)

Comment 1 Devrim GUNDUZ 2008-01-05 13:19:15 UTC
Cannot reproduce this error in the current releases. Closing bug.


Note You need to log in before you can comment on or make changes to this bug.