Bug 214831 - Yumex crashes on startup.
Yumex crashes on startup.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 214823 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 12:38 EST by Greg Douglas
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.0-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 04:09:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Douglas 2006-11-09 12:38:34 EST
Description of problem:

Since upgrading to FC6, Yumex no longer works.  An error message appears and
requests to post the problem to this repository.  Here is the error message:

Component: yumex
Version: 1.1.7
Summary: TBf0b64ae8 updates.py:584:getObsoletesList:AttributeError: Updates
instance has no attribute 'obsoletes'

Traceback (most recent call last):
  File "/usr/share/yumex/yumexmain.py", line 1102, in ?
    mainApp = YumexMainApplication()
  File "/usr/share/yumex/yumexmain.py", line 536, in __init__
    self.setup_yum()
  File "/usr/share/yumex/yumexmain.py", line 990, in setup_yum
    self.yumexbase.build_package_lists( self.recentlimit, pkglists )
  File "/usr/lib/python2.4/site-packages/yumex/yumexBase.py", line 449, in
build_package_lists
    updates = self.up.getUpdatesList() + self.up.getObsoletesList()
  File "/usr/lib/python2.4/site-packages/rpmUtils/updates.py", line 584, in
getObsoletesList
    tmplist = self.obsoletes.keys()
AttributeError: Updates instance has no attribute 'obsoletes'

Local variables in innermost frame:
newest: 0
self: <rpmUtils.updates.Updates instance at 0x9e412ec>
arch: None
name: None





Version-Release number of selected component (if applicable):

Version: 1.1.7

How reproducible:

Every time Yumex is loaded.  It worked fine in FC5.

Steps to Reproduce:
1. Open Yumex
2. It crashes during initialization after a few minues.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Greg Douglas 2006-11-09 12:39:23 EST
*** Bug 214823 has been marked as a duplicate of this bug. ***
Comment 2 Tim Lauridsen 2006-11-10 02:26:18 EST
do you have a
obsoletes=1
in /etc/yum.conf

place attach your /etc/yum.conf
Comment 3 Tim Lauridsen 2006-11-10 04:09:09 EST
Ok, it dont check for the obsoletes setting, it should be fixed in yumex 1.2,
just released.

Note You need to log in before you can comment on or make changes to this bug.