Bug 214855 - Error in execution of RPM clean-up for librsvg2
Error in execution of RPM clean-up for librsvg2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: librsvg2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 14:09 EST by Greg Douglas
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 13:34:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Douglas 2006-11-09 14:09:28 EST
Description of problem:

During Yum update of this package, the following message was sent to the terminal.

Not certain how critical problem is....


  Cleanup   : librsvg2                     ####################### [17/29]
/usr/bin/update-gdk-pixbuf-loaders: line 27:
/etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No such file or directory
error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed, exit status 1
  Cleanup   : librsvg2                     ####################### [18/29]





Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Florian Erfurth 2006-11-25 07:33:54 EST
Hi I've got the same problem. That is because the packages gtk2 and librsvg2 are
using different directories. On my system librsvg2 want to use the path
/etc/gtk-2.0/i386-redhat-linux-gnu/ which is wrong because there is
/etc/gtk-2.0/i686-redhat-linux-gnu/.
You can read the bugzilla entry at red hat enterprise linux, which describes the
problem very well. (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=143547#c3)
There is a errata for rhel-users, but what is with FC6 users? May we use this
errata until this problem is fixed in FC6?

cu Floh
Comment 2 Davide Bolcioni 2007-01-24 17:15:30 EST
I also encountered when upgrading from Fedora Core 5, but it probably got 
fixed by the combination of librsvg2-2.16.1-1.fc6 using %postun 
in "/usr/bin/update-gdk-pixbuf-loaders i686-redhat-linux-gnu" and 
gtk2-2.10.4-10.fc6 taking extra steps in /usr/bin/update-gdk-pixbuf-loaders.
Comment 3 Greg Douglas 2007-01-25 13:34:16 EST
Yup.  I am not seeing problems.

Thanks, this can be closed.
Comment 4 dex 2007-01-25 13:43:51 EST
No problems in rawhide also at last update:
librsvg2-2.16.1-1.fc7

Note You need to log in before you can comment on or make changes to this bug.