Bug 214881 - [RHEL5 Beta2] anaconda: fails to boot after install because of driveorder mis-match.
[RHEL5 Beta2] anaconda: fails to boot after install because of driveorder mis...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 15:47 EST by Kiyoshi Ueda
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: 11.1.2.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-12 10:48:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file for installation (3.35 KB, text/plain)
2006-11-09 15:49 EST, Kiyoshi Ueda
no flags Details
/root/anaconda-ks.cfg after installation (2.67 KB, text/plain)
2006-11-09 15:51 EST, Kiyoshi Ueda
no flags Details
/boot/grub/device.map after installation (63 bytes, text/plain)
2006-11-09 15:52 EST, Kiyoshi Ueda
no flags Details
/boot/grub/grub.conf after installation (825 bytes, text/plain)
2006-11-09 15:53 EST, Kiyoshi Ueda
no flags Details

  None (edit)
Description Kiyoshi Ueda 2006-11-09 15:47:26 EST
Description of problem:
anaconda doesn't install grub to the partition which specified
in the kickstart file, when driveorder change is specified.
As a result, system doesn't boot after the installation.


Version-Release number of selected component:
rel-eng/RHEL5-Server-20061102.2
    anaconda-11.1.2.11-1
nightly/RHEL5-Server-20061108.nightly
    anaconda-11.1.2.14-1


How reproducible:
Always


Steps to Reproduce:
 0. Prepare a system on which drive order is different between
    BIOS and OS. (e.g. the system has sda, sdb, sdc and sdd
    but they look as hd2, hd3, hd0 and hd1 from BIOS(=grub)
    respectively)
 1. Prepare kickstart file and specify "driveorder" like the attached
    ks.cfg.
    -----------------------------------------------------------------
      bootloader --location=partition --driveorder=sdc,sdd,sda,sdb
    -----------------------------------------------------------------
 2. Start kickstart installation.
 3. Boot the system.


Actual results:
The system doesn't boot.

The driverorder in the /root/anaconda-ks.cfg of after installation
is different from the kickstart file.
----------------------------------------------------------------
bootloader --location=partition --driveorder=sda,sdb,sdc,sdd \
--append="nodmraid rhgb quiet"
----------------------------------------------------------------

And sdc is mapped as hd2 in the /boot/grub/device.map.
-----------------------------------------------
# this device map was generated by anaconda
(hd2)     /dev/sdc
-----------------------------------------------


Expected results:
The system boots correctly.

Technically, driveorder should be same as specified in kickstart file.
And for example, sdc should be mapped as hd0 and grub should be
installed to /dev/sdc8 as specified in the sample ks.cfg.


Additional info:
rel-eng/RHEL5-Server-20061020.1 works fine.

Following files are attached:
    ks.cfg          : kickstart file which is used for installation
    anaconda-ks.cfg : /root/anaconda-ks.cfg after installation
    device.map      : /boot/grub/device.map after installation
    grub.conf       : /boot/grub/grub.conf after installation
Comment 1 Kiyoshi Ueda 2006-11-09 15:49:38 EST
Created attachment 140826 [details]
kickstart file for installation
Comment 2 Kiyoshi Ueda 2006-11-09 15:51:15 EST
Created attachment 140827 [details]
/root/anaconda-ks.cfg after installation
Comment 3 Kiyoshi Ueda 2006-11-09 15:52:33 EST
Created attachment 140828 [details]
/boot/grub/device.map after installation
Comment 4 Kiyoshi Ueda 2006-11-09 15:53:19 EST
Created attachment 140829 [details]
/boot/grub/grub.conf after installation
Comment 5 RHEL Product and Program Management 2006-11-13 08:00:40 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 6 Chris Lumens 2006-11-21 15:49:09 EST
This should be fixed in a milestone tree with anaconda-11.1.2.17 and
booty-0.80.2.  Please test and report your success or failure.
Comment 7 Kiyoshi Ueda 2006-11-22 15:50:52 EST
I confirmed that this bug is fixed in rel-eng/RHEL5-Server-20061111.0,
though anaconda is 11.1.2.16 and booty is 0.80-1.
Since I don't know why the problem didn't occur in the rel-eng,
I will test again with a latest tree which includes these new packages.

FYI, here is the anaconda-ks.cfg of when I tried the rel-eng.
======================================================================================
# Kickstart file automatically generated by anaconda.

install
nfs --server=bigpapi.boston.redhat.com
-dir=/vol/engineering/redhat/rel-eng/RHEL5-Server-20061111.0/4.92/i386/os
key 1
lang ja_JP.UTF-8
keyboard us
skipx
network --device eth0 --bootproto dhcp --hostname nec-em4.boston.redhat.com
rootpw --iscrypted $1$fYU.fpoj$IZqVRSIcgCRHjhisfC6Ju/
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc America/New_York
bootloader --location=partition
--driveorder=sdc,sdd,mapper/ddf1_4035305a8680c3272020202020202020288efe0b3a354a45
--append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#part /boot --fstype ext3 --onpart sdc8
#part /mnt/0 --fstype ext3 --noformat --onpart sdc14
#part /mnt/1 --fstype ext3 --noformat --onpart sdc15
#part swap --noformat --onpart sdd3
#part swap --noformat --onpart sdc3
#part / --fstype ext3 --onpart sdc9
#part pv.20 --noformat --onpart sdd2
#volgroup rootvg --noformat --useexisting --pesize=4096 pv.20

%packages
@base
@core
.....
======================================================================================
Comment 8 Kiyoshi Ueda 2006-12-12 10:31:05 EST
I confirmed that this bug is fixed in RHEL5-Server-20061207.4
which includes anaconda-11.1.2.20-1 and booty-0.80.2-1.

FYI, anaconda-ks.cfg is below.
==========================================================================
# Kickstart file automatically generated by anaconda.

install
nfs --server=bigpapi.boston.redhat.com
--dir=/vol/engineering/redhat/rel-eng/RHEL5-Server-20061207.4/4.92/i386/os
key 1
lang ja_JP.UTF-8
keyboard us
skipx
network --device eth0 --bootproto dhcp --hostname nec-em4.boston.redhat.com
rootpw --iscrypted $1$fYU.fpoj$IZqVRSIcgCRHjhisfC6Ju/
firewall --disabled
authconfig --enableshadow --enablemd5
selinux --enforcing
timezone --utc America/New_York
bootloader --location=partition
--driveorder=sdc,sdd,fd0,mapper/ddf1_4035305a8680c3272020202020202020288efe0b3a354a45
--append="rhgb quiet"
# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
#part /boot --fstype ext3 --onpart sdc8
#part swap --noformat --onpart sdc3
#part /mnt/0 --fstype ext3 --noformat --onpart sdc14
#part /mnt/1 --fstype ext3 --noformat --onpart sdc15
#part swap --noformat --onpart sdd3
#part pv.20 --noformat --onpart sdd2
#part / --fstype ext3 --onpart sdc9
#volgroup rootvg --noformat --useexisting --pesize=4096 pv.20

%packages
@base
@core
.....
==========================================================================

Note You need to log in before you can comment on or make changes to this bug.