This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 214898 - Things are deprecated and will be removed from a future kernel
Things are deprecated and will be removed from a future kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-09 16:37 EST by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-26 06:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2006-11-09 16:37:22 EST
Description of problem:
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:75
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:233
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:235
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: do not reference parent sysfs 
directories directly, that may break with a future kernel,please fix it in /etc/
udev/rules.d/50-udev.rules:248
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: DRIVER== will change in a future 
relase, please use DRIVERS== in /etc/udev/rules.d/50-udev.rules:264
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: do not reference parent sysfs 
directories directly, that may break with a future kernel,please fix it in /etc/
udev/rules.d/50-udev.rules:265
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:329
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:330
Nov  9 21:37:29 tux udevd[20486]: add_to_rules: the 'device' link is deprecated 
and will be removed from a future kernel, please fix it in /etc/udev/rules.d/50-
udev.rules:331

Version-Release number of selected component (if applicable):
udev-103-1
kernel-2.6.18-1.2798

How reproducible:
Everytime when upgrading udev to 103-1.

Actual results:
Things are deprecated and will be removed from a future kernel

Expected results:
No deprecated stuff would be nice...

Additional info:
Don't you test new releases before pushing it into Rawhide? :-(
Comment 1 Daniel Malmgren 2006-11-10 02:29:09 EST
I get this too. But hey, this is development, isn't it? ;-)
Comment 2 Harald Hoyer 2006-11-10 04:26:37 EST
We don't test... you do :) Just kidding.. :)
Comment 3 Ralf Ertzinger 2006-11-10 05:41:11 EST
Although I consider those messages warnings (so things ought to work
nonetheless) I no longer get device nodes made for my external USB-DVD-DW.

Manually inserting usb-storage and sr-mod makes the nodes appear, however.
Comment 4 Harald Hoyer 2006-11-13 05:51:36 EST
udev-103-2
Comment 5 Michal Jaegermann 2006-11-18 14:11:41 EST
I do have udev-103-2 installed and I am still seeing on a startup

Starting udev: udevd[419]: add_to_rules: DRIVER== will change in a future
relase, please use DRIVERS== in /etc/udev/rules.d/50-udev.rules:264

What is more the only rule with 'DRIVER' in it in the whole /etc/udev/rules.d
directory is in line 268 of /etc/udev/rules.d/50-udev.rules and it
reads:

BUS=="ide", DRIVER!="ide-cdrom", ATTRS{removable}=="1",     GOTO="persistent_end"

Lines 264 to 267 are comments.

To add to this picture /usr/share/doc/udev-103/writing_udev_rules/index.html
gives explicit examples with 'DRIVER==...' and does not mention
anything about 'DRIVERS'.
Comment 6 Robert Scheck 2006-12-09 13:51:00 EST
Using udev-103-3:

Dec  9 19:47:44 tux udevd[2639]: add_to_rules: DRIVER== will change in a future
relase, please use DRIVERS== in /etc/udev/rules.d/50-udev.rules:264
Dec  9 19:47:44 tux udevd[24053]: init_udevd_socket: bind failed: Address 
already in use
Dec  9 19:47:44 tux udevd[24053]: main: another udev daemon already running
Comment 7 Robert Scheck 2006-12-19 18:13:27 EST
Ping?
Comment 8 Ralf Ertzinger 2006-12-20 04:52:17 EST
Current rawhide (kernel-2.6.19-1.2885.fc7, udev-103-3) works for me.
Comment 9 Michal Jaegermann 2007-01-26 13:47:48 EST
This bug was CLOSED RAWHIDE and indeed now one can find in
/etc/udev/rules.d/50-udev.rules: BUS=="ide", DRIVERS!="ide-cdrom", ...
but documentation in /usr/share/doc/udev-104/writing_udev_rules/index.html
still talks only about DRIVER and nothing about DRIVERS (not
mentioning any possible differences between these two).

Should that be opened as a separate bug?

Note You need to log in before you can comment on or make changes to this bug.