Bug 214900 - HTS: Virt test fails on Dell Precision 380
HTS: Virt test fails on Dell Precision 380
Status: CLOSED DUPLICATE of bug 217943
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: YangKun
: Reopened
: 215606 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-11-09 16:47 EST by Irina Boverman
Modified: 2007-04-18 13:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-12-13 16:32:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Irina Boverman 2006-11-09 16:47:01 EST
Description of problem:
Fails with errors
Version-Release number of selected component (if applicable):

How reproducible:

hts certify -t virt

Actual results:

 hts certify -t virt
loaded test results /var/hts/results.xml
running only test virt
running virt on General
mkdir -p /tmp/hts-virt-5rRFsf/mnt/tests/HTS/hts/virt
cp -a testinfo.desc runtest.sh Makefile virt.sh Makefile
cp: warning: source file `Makefile' specified more than once
install -m 0755 runtest.sh /tmp/hts-virt-5rRFsf/mnt/tests/HTS/hts/virt
make OUTPUTFILE=/var/log/hts/runs/2/virt/output.log RUNMODE=normal UDI=General run
chmod a+x ./runtest.sh ./virt.sh
Running ./virt.sh:
./virt.sh: line 323: [: ==: unary operator expected
./virt.sh: line 326: [: ==: unary operator expected
Error ! This machine does not have hardware support for virtualization !
...finished running ./virt.sh, exit code=1
recovered exit code=1
rhts-report-result /HTS/hts/virt FAIL /var/log/hts/runs/2/virt/output.log
saveOutput: /var/log/hts/runs/2/virt/output.log
Return value was 0

Expected results:

Additional info:
Comment 1 Irina Boverman 2006-11-09 17:18:10 EST
Need to add para-virt guest test.
Test output should clearly indicate which (para or full) guest test is being
executed and why.
Comment 2 YangKun 2006-11-09 23:39:38 EST
Currently, the virt test only runs on machines which have hardware support for
virtualization(Intel VT or AMD-V) and only create a FV guestOS. Will add the
support for non-Intel-VT(AMD-V) machines(must be PAE-enabled machines) in the
next release.
Comment 3 Irina Boverman 2006-11-10 12:05:41 EST
This bug should remain open until we have new test. There are also script
problems with existing test that should be resolved as well.
Comment 4 Irina Boverman 2006-11-29 17:04:38 EST
Tried new paravirt test a couple of times without success. Latest attempt was
made using hts 5.0.12. Virt test requires 1 gb of memory, which is incorrect,
and exits without running. 
Comment 5 Irina Boverman 2006-12-01 15:45:13 EST
We no longer need to run PV guest for RHEL 5 certification. We need to change
"plan" to exclude virt test on non-FV machines.
Comment 6 Irina Boverman 2006-12-01 15:48:41 EST
*** Bug 215606 has been marked as a duplicate of this bug. ***
Comment 7 Danny Trinh 2006-12-05 14:20:05 EST
It still failed with hts-5.0.13 and rhel5-i386-beta2.
Comment 8 YangKun 2006-12-06 03:53:10 EST
some changes on virt test are made since hts-5.0.13 . please wait for the next
version, should be hts-5.0.14
Comment 9 Irina Boverman 2006-12-07 17:17:42 EST
"plan" still includes virt test on PV machine using hts-5.0.14.
Comment 10 Greg Nichols 2006-12-13 16:32:11 EST

*** This bug has been marked as a duplicate of 217943 ***

Note You need to log in before you can comment on or make changes to this bug.