Bug 214923 - xorg-x11-xfs depends on coreutils
Summary: xorg-x11-xfs depends on coreutils
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: comps   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-09 23:31 UTC by Ahmon Dancy
Modified: 2018-04-11 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 19:42:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ahmon Dancy 2006-11-09 23:31:06 UTC
/etc/rc.d/init.d/xfs uses 'uniq' which is part of the coreutils package but the
xorg-x11-xfs RPM does not have a coreutils dependency listed.

I ran across this issue today when I did a kickstart installation using the
following package list:

%packages
@admin-tools
@base
@core
@development-libs
@development-tools
@dial-up
@editors
@java
@printing
@text-internet
@x-software-development
comps-extras
cracklib-dicts
gnome-mime-data
kernel-headers
nash
rmt
tzdata
xorg-x11-util-macros

----------

I suppose this could be considered a two-part bug since it's surprising that
'coreutils' isn't part of the @core group.

Comment 1 Matěj Cepl 2006-12-28 22:15:23 UTC
Per
http://fedoraproject.org/wiki/Packaging/Guidelines#head-4cadce5e79d38a63cad3941de1dadc9d25d67d30
coreutils are not to be put into BuildRequires and Requires headers of spec file.

Comment 2 Ahmon Dancy 2006-12-28 22:19:54 UTC
OK.

So, should I file a new bug to say that 'coreutils' should be included in the
@core group?


Comment 4 Chris Lumens 2006-12-30 18:15:15 UTC
We should check the comps file to make sure that coreutils is listed in base or
core.

Comment 5 Jesse Keating 2007-01-02 19:42:24 UTC
coreutils is manditory in the @core group.


Note You need to log in before you can comment on or make changes to this bug.