Bug 21497 - unable to login root or user account after install
Summary: unable to login root or user account after install
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-29 19:55 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-07 16:48:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-11-29 19:55:23 UTC
HELP !!! 

When I try login as root or my userid created during installation
after supplying password, the system simply jumps back to local host 
prompting for username again ?????

tried changing root password trough ssh ,,still did not help ?

Thanks
Julian

Comment 1 Need Real Name 2000-12-01 22:23:09 UTC
HOW DO I GET TO RESOLVE THIS ?
I TRIED LINUX SINGLE AND USED PASSWD ROOT AT THE # PROMPT TO CHANGE
THE PASSWORD AS WELL ?
STILL THE SAME PROBLEM 
PLEASE ASSIST AS MY SYSTEM IS NOW UNUSABLE
THANKS

Comment 2 Nalin Dahyabhai 2000-12-01 23:45:32 UTC
Which authentication schemes have you enabled?  MD5?  Shadow?  Is this a fresh 7
install, or an upgrade from a previous release?  Are there any relevant messages
in /var/log/messages?

Comment 3 Need Real Name 2000-12-02 14:51:39 UTC
Hi

to reply :

I have both shadow and md5 enabled similar to my previous 6.2 installation
(which was sucessfull). I also selected LDAP & KEREBOS on that screen during 
install which was new to me and not available to select on 6.2.

This was not a upgrade but a fresh install with formatting.

I checked /var/log/messages through vi and found a lot of messages, what to 
look for is not clear for me but I noticed the following and hope it can 
assist :

- a lot of stuff indicating disabled ,removing . starting with AMANDAIDX 
  I also noticed the following disabled & removed :
  - eklogin
  - exec
  and plenty other stuff ....

- I also found this in /var/log/messages?
  - Localhost PAM_unix [904] : authentication failure Login (uid = 0) ->
    root for system auth services
  - Localhost PAM_unix [912] : check pass; user unknown
  - Localhost PAM_unix [912] : authentication failure Login (uid = 0) ->
    r045 for system services 

Someone in my newsgroup also asked me to check /etc/securetty for listings of 
tty1 & tty2 ... etc.
I checked it and found the following :
vc/1 to vc/11 &
tty1 to tty11.
 
Thanks 
Julian

 


Comment 4 Need Real Name 2000-12-03 19:42:38 UTC
Hi 

I couldn't wait anylonger to get up & running as my online course and usergroup
was starting to gain too much on me.
So I decided to reinstall (would have liked to be able to fix instead, unlike 
windows....)

Anyways, I reinstalled and the only difference was not to select LDAP & KEREBOS.
NIS I never selected the first time around anyway!
So, the only items selected during install was md5 & shadow......

The system seems ok now and I am able to login....

Thanks for the assistance,,,(just not happy that I still don't understand what 
the problem was)

Thanks again
Julian

Comment 5 Need Real Name 2000-12-07 16:48:32 UTC
Hi

Could you tell me if ever there was a conclusion to this problem or maybe still 
working on a solution ?

Thanks 
Julian

Comment 6 Nalin Dahyabhai 2000-12-07 16:52:53 UTC
A "user unknown" error usually means that there was some problem accessing the
/etc/passwd file, either because it was somehow corrupted or removed.  We were
never able to reproduce it (my own workstation uses both LDAP and Kerberos with
our internal servers, and this hasn't happened).


Note You need to log in before you can comment on or make changes to this bug.