Bug 214987 - File ownership not respected 'in normal way' on file uploads
Summary: File ownership not respected 'in normal way' on file uploads
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: vsftpd (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Maros Barabas
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-10 14:30 UTC by Simon Brock
Modified: 2008-08-02 23:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 18:40:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of vsftpd permission/ownership issue (1.55 KB, text/plain)
2006-11-18 07:52 UTC, Jonathan kelly
no flags Details

Description Simon Brock 2006-11-10 14:30:06 UTC
Description of problem:

The version of vsftpd that ships with RHEL3 has an introduced bug from the RedHat bug fix 171308 
which is here:

http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=171308

which allows you to overwrite other people's file in a surprising way. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. say you have a group called workers containing two users fred and george
2. say you have a directory which is group writable which contains a file owned by fred but that file is 
not group writable (e.g. mode 0644).
3. with real vsftpd george cannot overwrite the file on upload;
4. with RedHat vsftpd george can overwrite the file because when a file is uploaded, it is uploaded to a 
new name and then renamed over the old one (as per the bug fix above).
  
Actual results:

Confused users as they don't expect their files to be overwritten without warning. They know they can 
be overwritten (with effort).


Expected results:

553 Could not create file.


Additional info:
The original bug fix would have been ok if you could turn off the facility (concurrent writes is a fact of 
Unix life)

Comment 1 Jonathan kelly 2006-11-18 07:52:23 UTC
Created attachment 141551 [details]
Example of vsftpd permission/ownership issue

Comment 2 Jonathan kelly 2006-11-18 07:54:04 UTC
I have verified this issue on multiple servers: rather than writing to the
existing file on uploading, a new file is created and moved over the existing
one, resetting ownership and permissions to defaults.  This appears to have
started with the most recent RHEL3 update to vsftpd.  See attached text file for
an example.

Comment 3 Jonathan kelly 2006-11-18 08:58:08 UTC
(In reply to comment #2)
> I have verified this issue on multiple servers: rather than writing to the
> existing file on uploading, a new file is created and moved over the existing
> one, resetting ownership and permissions to defaults.  This appears to have
> started with the most recent RHEL3 update to vsftpd.  See attached text file for
> an example.

Pardon the not reading the entire post.  Doh.

Comment 4 Maros Barabas 2007-05-24 07:59:17 UTC
Please try the last version of vsftpd from here:
http://people.redhat.com/rbiba/maros/vsftpd-1.2.1-3E.11.src.rpm

It works for me. Thanks

Comment 5 RHEL Product and Program Management 2007-10-19 18:40:03 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.