Bug 215074 - "/etc/init.d/network status" doesn't show active devices; loopback goes away on APM suspend/resume
Summary: "/etc/init.d/network status" doesn't show active devices; loopback goes away ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-10 20:12 UTC by Scott Guthridge
Modified: 2014-03-17 03:03 UTC (History)
1 user (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 20:15:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /etc/init.d/network network UP flag parsing regex (326 bytes, patch)
2006-11-10 20:12 UTC, Scott Guthridge
no flags Details | Diff

Description Scott Guthridge 2006-11-10 20:12:44 UTC
Description of problem: The "status" command of the /etc/init.d/network script
fails to report active network interfaces.

And because /etc/sysconfig/apm-scripts/apmscript uses this to decide which
network interfaces should be restarted after a resume, my network interfaces
(including "lo") all disappear when I come out of suspend mode.

Version-Release number of selected component: initscripts-8.11.1-1


How reproducible:

    # service network status
   
Actual results:
    Configured devices:
    lo eth0 eth1 wifi0
    Currently active devices:


Expected results:
    Configured devices:
    lo eth0 eth1 wifi0
    Currently active devices:
    lo eth0


      

Additional info:

    Problem line is:

        echo `/sbin/ip -o link show | awk -F ": " '/UP>/ { print $2 }'`

    Problem is that /sbin/ip -o link show output doesn't necessarily report
    the interface UP bit last because the (current) 2.6.17-1.2142_FC4 kernel
    is reporting an extra flag after UP.

        1: lo: <LOOPBACK,UP,10000> mtu 16436 qdisc noqueue \    link/loopback  
 00:00:00:00:00:00 brd 00:00:00:00:00:00
        2: eth0: <BROADCAST,MULTICAST,UP,10000> mtu 1500 qdisc pfifo_fast qlen
1000\ link/ether 00:09:6b:c2:72:fe brd ff:ff:ff:ff:ff:ff
        3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000\   
link/ether 00:d0:59:c8:b6:dc brd ff:ff:ff:ff:ff:ff
        4: wifi0: <BROADCAST,MULTICAST> mtu 2312 qdisc pfifo_fast qlen 100\   
link/ieee802.11 00:d0:59:c8:b6:dc brd ff:ff:ff:ff:ff:ff
        5: sit0: <NOARP> mtu 1480 qdisc noop \    link/sit 0.0.0.0 brd 0.0.0.0

Comment 1 Scott Guthridge 2006-11-10 20:12:45 UTC
Created attachment 140932 [details]
patch for /etc/init.d/network network UP flag parsing regex

Comment 2 Bill Nottingham 2006-11-10 20:15:19 UTC
This is fixed in the current FC6 initscripts.


Note You need to log in before you can comment on or make changes to this bug.