Bug 215080 - KlamAV requires Dazuko
KlamAV requires Dazuko
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: klamav (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Andy Shevchenko
Fedora Extras Quality Assurance
http://www.dazuko.org/faq.shtml
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 15:34 EST by john
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 01:05:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description john 2006-11-10 15:34:42 EST
Description of problem:
Klamav requires Dazuko kernel module to scan files. This is not provided and is
not easily installed without recompiling the kernel. Please include this kernel
module when KlamAV/Clamav is installed.

Version-Release number of selected component (if applicable):
klamav-0.38-4.fc6 / clamav-0.88.6-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. Install Klamav
2. Attempt to set up automatic file system scan
3. Watch the error message pop up.
  
Actual results:
Error message pops up that Dazuko could not be loaded

Expected results:
Dazuko module would be loaded and Klamav/Clamav would happily allow you to
configure automatic scanning of the file system.

Additional info:
Comment 1 Andy Shevchenko 2006-11-14 09:59:36 EST
Sorry. I'd like to get some details. Is dazuko can be build as kmod (for Fedora 
kernels of course) w/o kernel recompilation? Where can I get good dazuko build 
description step-by-step? If you answer 'yes' should I try inject dazuko-kmod 
to Fedora Extras?
Comment 2 john 2006-11-14 10:19:46 EST
(In reply to comment #1)
> Sorry. I'd like to get some details. Is dazuko can be build as kmod (for Fedora 
> kernels of course) w/o kernel recompilation? Where can I get good dazuko build 
> description step-by-step? If you answer 'yes' should I try inject dazuko-kmod 
> to Fedora Extras?
> 
I really don't know much about it. I did some research and found this page on
the Dazuko website: http://www.dazuko.org/gen.shtml#PRECOMPILED Basically it
says "However, since Dazuko must load into the kernel itself, Dazuko must be
compiled with exactly the same code that your kernel was compiled with." I would
think that if you could get ahold of a standard Fedora kernel source, you could
unpack it, compile it, etc. Here's instructions on how to compile:
http://www.dazuko.org/tgen.shtml#CONFIGURE-SOURCE

I don't know how to build an RPM from scratch, or I'd offer to help.
Comment 3 Andy Shevchenko 2006-11-15 04:24:59 EST
Thanks. I've deep into given URLs and try to understand what can I do.
Comment 4 Andy Shevchenko 2006-11-15 07:34:54 EST
My investigation shows that Fedora Core kernels are compiled with
 CONFIG_SECURITY_CAPABILITIES=y
but dazuko module requires
 CONFIG_SECURITY_CAPABILITIES=m

Thus, the klamav can't use the dazuko due to last can't be built under Fedora.
I advise you to fill bug to Fedora kernel component and I attach dependence to 
it.

Note You need to log in before you can comment on or make changes to this bug.