Bug 215101 - kobject_add failed for vcsa63 with -EEXIST, DWARF2 unwinder stuck
kobject_add failed for vcsa63 with -EEXIST, DWARF2 unwinder stuck
Status: CLOSED DUPLICATE of bug 212109
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 17:23 EST by James
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-19 16:44:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
portion of /var/log/messages (2.89 KB, text/plain)
2006-11-25 15:42 EST, John Reiser
no flags Details

  None (edit)
Description James 2006-11-10 17:23:18 EST
Description of problem:
I have seen a kobject_add failed for vcs63 with -EEXIST with DWARF2 unwinder
stuck shortly before suspending-to-RAM. Nothing special was going on at the
time. The notebook had just been hard-reset after failing to resume from
suspend-to-RAM properly previously.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
Unknown.

Actual results:
kobject_add failed for vcs63 with -EEXIST, don't try to register things with the
same name in the same directory.
 [<c04051db>] dump_trace+0x69/0x1af
 [<c0405339>] show_trace_log_lvl+0x18/0x2c
 [<c04058ed>] show_trace+0xf/0x11
 [<c04059ea>] dump_stack+0x15/0x17
 [<c04e4e56>] kobject_add+0x165/0x18e
 [<c05531ab>] class_device_add+0xa2/0x3de
 [<c0553579>] class_device_create+0x82/0xa2
 [<c0536ebc>] vcs_make_devfs+0x3c/0x7e
 [<c053bd89>] con_open+0x6f/0x7c
 [<c0532654>] tty_open+0x182/0x307
 [<c0476c0a>] chrdev_open+0xfb/0x12f
 [<c046dbc6>] __dentry_open+0xc7/0x1ab
 [<c046dd24>] nameidata_to_filp+0x24/0x33
 [<c046dd65>] do_filp_open+0x32/0x39
 [<c046ddae>] do_sys_open+0x42/0xbe
 [<c046de63>] sys_open+0x1c/0x1e
 [<c0404013>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 =======================
kobject_add failed for vcsa63 with -EEXIST, don't try to register things with
the same name in the same directory.
 [<c04051db>] dump_trace+0x69/0x1af
 [<c0405339>] show_trace_log_lvl+0x18/0x2c
 [<c04058ed>] show_trace+0xf/0x11
 [<c04059ea>] dump_stack+0x15/0x17
 [<c04e4e56>] kobject_add+0x165/0x18e
 [<c05531ab>] class_device_add+0xa2/0x3de
 [<c0553579>] class_device_create+0x82/0xa2
 [<c0536ef9>] vcs_make_devfs+0x79/0x7e
 [<c053bd89>] con_open+0x6f/0x7c
 [<c0532654>] tty_open+0x182/0x307
 [<c0476c0a>] chrdev_open+0xfb/0x12f
 [<c046dbc6>] __dentry_open+0xc7/0x1ab
 [<c046dd24>] nameidata_to_filp+0x24/0x33
 [<c046dd65>] do_filp_open+0x32/0x39
 [<c046ddae>] do_sys_open+0x42/0xbe
 [<c046de63>] sys_open+0x1c/0x1e
 [<c0404013>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 =======================
Comment 1 John Reiser 2006-11-25 15:42:00 EST
Created attachment 142123 [details]
portion of /var/log/messages
Comment 2 John Reiser 2006-11-25 15:44:07 EST
I can reproduce this at any time by System > Suspend.  kernel-2.6.18-1.2798.fc6
on PowerPC Apple Macintosh G4.  See above Comment #1 for log.
Comment 3 Partha Bagchi 2007-02-19 07:20:54 EST
Here is what happens to me on my dv8000 (AMD64, x86_64, ATI 200M with fglrx 8.33.6):
_________________________________________________________________________
Feb 19 00:30:14 NiTuan gnome-power-manager: (root) Suspending computer because
the suspend button has been pressed
Feb 19 00:30:17 NiTuan kernel: kobject_add failed for vcs63 with -EEXIST, don't
try to register things with the same name in the same directory.
Feb 19 00:30:17 NiTuan kernel: 
Feb 19 00:30:17 NiTuan kernel: Call Trace:
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8026999a>] show_trace+0x34/0x47
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff802699bf>] dump_stack+0x12/0x17
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80343e82>] kobject_add+0x174/0x19f
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803af888>] class_device_add+0xb2/0x464
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803afd27>] class_device_create+0xdb/0x10a
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80394132>] vcs_make_sysfs+0x2d/0x5b
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803995d5>] con_open+0x7c/0x8b
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80391807>] tty_open+0x1ad/0x36c
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8024792f>] chrdev_open+0x149/0x198
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8021e831>] __dentry_open+0xd9/0x1df
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80227b55>] do_filp_open+0x2a/0x38
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80219a1d>] do_sys_open+0x44/0xbe
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8025c11e>] system_call+0x7e/0x83
Feb 19 00:30:17 NiTuan kernel:  [<00000030958bf480>]
Feb 19 00:30:17 NiTuan kernel: 
Feb 19 00:30:17 NiTuan kernel: kobject_add failed for vcsa63 with -EEXIST, don't
try to register things with the same name in the same directory.
Feb 19 00:30:17 NiTuan kernel: 
Feb 19 00:30:17 NiTuan kernel: Call Trace:
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8026999a>] show_trace+0x34/0x47
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff802699bf>] dump_stack+0x12/0x17
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80343e82>] kobject_add+0x174/0x19f
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803af888>] class_device_add+0xb2/0x464
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803afd27>] class_device_create+0xdb/0x10a
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff803995d5>] con_open+0x7c/0x8b
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80391807>] tty_open+0x1ad/0x36c
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8024792f>] chrdev_open+0x149/0x198
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8021e831>] __dentry_open+0xd9/0x1df
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80227b55>] do_filp_open+0x2a/0x38
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff80219a1d>] do_sys_open+0x44/0xbe
Feb 19 00:30:17 NiTuan kernel:  [<ffffffff8025c11e>] system_call+0x7e/0x83
Feb 19 00:30:17 NiTuan kernel:  [<00000030958bf480>]
Feb 19 00:30:17 NiTuan kernel: 
____________________________________________________________________________ 
Comment 4 James 2007-02-23 12:33:14 EST
Got this recently shortly after a resume on kernel 2.6.19-1.2911.fc6.

kobject_add failed for vcs63 with -EEXIST, don't try to register things with the
same name in the same directory.
 [<c0405018>] dump_trace+0x69/0x1b6
 [<c040517d>] show_trace_log_lvl+0x18/0x2c
 [<c0405778>] show_trace+0xf/0x11
 [<c0405875>] dump_stack+0x15/0x17
 [<c04eecf2>] kobject_add+0x16d/0x196
 [<c055eee4>] class_device_add+0xa2/0x3f6
 [<c055f2ca>] class_device_create+0x82/0xa2
 [<c0542624>] vcs_make_sysfs+0x3c/0x7e
 [<c0547510>] con_open+0x6f/0x7c
 [<c053d31a>] tty_open+0x182/0x307
 [<c0477d62>] chrdev_open+0xfb/0x12f
 [<c04742f7>] __dentry_open+0xc7/0x1ab
 [<c0474455>] nameidata_to_filp+0x24/0x33
 [<c0474496>] do_filp_open+0x32/0x39
 [<c04744df>] do_sys_open+0x42/0xbe
 [<c0474594>] sys_open+0x1c/0x1e
 [<c040404b>] syscall_call+0x7/0xb
 [<00cae402>] 0xcae402
 =======================
kobject_add failed for vcsa63 with -EEXIST, don't try to register things with
the same name in the same directory.
 [<c0405018>] dump_trace+0x69/0x1b6
 [<c040517d>] show_trace_log_lvl+0x18/0x2c
 [<c0405778>] show_trace+0xf/0x11
 [<c0405875>] dump_stack+0x15/0x17
 [<c04eecf2>] kobject_add+0x16d/0x196
 [<c055eee4>] class_device_add+0xa2/0x3f6
 [<c055f2ca>] class_device_create+0x82/0xa2
 [<c0542661>] vcs_make_sysfs+0x79/0x7e
 [<c0547510>] con_open+0x6f/0x7c
 [<c053d31a>] tty_open+0x182/0x307
 [<c0477d62>] chrdev_open+0xfb/0x12f
 [<c04742f7>] __dentry_open+0xc7/0x1ab
 [<c0474455>] nameidata_to_filp+0x24/0x33
 [<c0474496>] do_filp_open+0x32/0x39
 [<c04744df>] do_sys_open+0x42/0xbe
 [<c0474594>] sys_open+0x1c/0x1e
 [<c040404b>] syscall_call+0x7/0xb
 [<00cae402>] 0xcae402

It was followed shortly after with an AE_TIME exception, a la bug 229546.
Comment 5 Dave Jones 2007-03-19 16:44:19 EDT

*** This bug has been marked as a duplicate of 212109 ***

Note You need to log in before you can comment on or make changes to this bug.