Bug 215109 - GFS2 is broken in fc6
GFS2 is broken in fc6
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Whitehouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 18:31 EST by Yevheniy Demchenko
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-27 04:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Yevheniy Demchenko 2006-11-10 18:31:33 EST
Description of problem:


Version-Release number of selected component (if applicable):
2.6.18-1.2835.fc6

How reproducible:


Steps to Reproduce:
1.Install cman,clvmd,gfs2-utils
2.create 3-node cluster
3.share some data on node1 via iscsi
4.connect iscsi devices on node2 and node3 (assume, it is connected as /dev/sdc)
5.create partition on  dev/sdc1 via fdisk
6.on node2 or node3 mkfs.gfs2 with -p lock_dlm on this partition
7.mount gfs2 fs on nodes2 and3
8.try simultanious writes (actually tried to copy 200M different files using mc)
from nodes 2 and 3 to the mounted gfs2 fs.
  
Actual results:
nodes 2 and 3 file I/O completely freezes on gfs2 fs

Expected results:
gfs2 fs operable

Additional info:
Also tried with clvmd and shared lvs. The same behaviour.
clvmd doesn't work _at_all_ on 2798 kernel release.
Comment 1 Yevheniy Demchenko 2006-11-10 20:33:27 EST
Update: if device is shared via gnbd, not iscsi, gfs2 works while writing
different files, but deadlocks while trying to write to the same file from
different nodes.
Comment 2 Steve Whitehouse 2006-11-24 07:16:00 EST
Is it possible to reproduce with gnbd and then use sysrq to get a dump of which
processes are hanging? echo 't' >/proc/sysrq-trigger should do the trick.

If you are still having problems with clvmd and/or iscsi, then please report
them as a separate bug as someone else will look into that.
Comment 3 Steve Whitehouse 2007-03-27 04:53:31 EDT
We've fixed a few bugs since this was reported which probably include the cause
of this bug. As a result and due to the lack of further information, I'm closing
this bug for the time being. If its still a problem, please reopen, or file
another bug.

Note You need to log in before you can comment on or make changes to this bug.