Bug 215118 - Warning on gnome-vfs2 install
Warning on gnome-vfs2 install
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 21:39 EST by Michel Alexandre Salim
Modified: 2015-03-03 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-vfs2-2.20.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 08:55:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2006-11-10 21:39:18 EST
Description of problem:


Version-Release number of selected component (if applicable):
2.16.2-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. rpm -e --nodeps gnome-vfs2
2. yum install gnome-vfs2
  
Actual results:
At the end of the install, I get the following: 
I/O warning : failed to load external entity " "
Failed to open ` ': No such file or directory


Expected results:
No failure should occur

Additional info:
This is on an x86_64 system, so yum installed both i386 and x86_64 versions.
Both gave the same error.
Comment 1 Michal Jaegermann 2006-11-15 14:29:32 EST
Not only warnings about 'external entity " "' are printed but long
lists of first of uninstalled and later installed asorted schemas
are dumped to a screen and that despite of a presens of
'gconftool-2 --makefile-uninstall-rule .... > /dev/null || :',
and similar, in package scripts.  Apparently gconftool-2 started
to print all that information on stderr.

Either we truly do not care about a status of these commands,
ss suggested by "... || :", and then it should be "> /dev/null 2>&1",
or we want to see warnings; but then better make just an information
to show on stdout and package scripts are fine like they are. 
Comment 2 Alexander Larsson 2006-11-20 10:26:12 EST
I don't understand this, but i suspect this change:

* Wed Oct 18 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-6
- Fix scripts according to packaging guidelines

Matthias, have you seen this issue before?

Comment 3 Matthias Clasen 2006-11-20 12:03:28 EST
Alex, I probably just forgot to replace > /dev/null by >& /dev/null
Comment 4 Alexander Larsson 2006-11-20 13:26:50 EST
The ScriptletSnippets doesn't have >& or 2>&1 though. Did something change to
cause this...
It seems a bit bad to drop the stderr, because that could signal some actual
problem.
Comment 5 David Juran 2008-02-01 08:55:27 EST
This seems to work fine with gnome-vfs2-2.20.1-1.fc8 in F8.

Note You need to log in before you can comment on or make changes to this bug.