Bug 215119 - The launch Mail Reader action opens a Thunderbird Mail compose window.
The launch Mail Reader action opens a Thunderbird Mail compose window.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mail-notification (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-10 22:08 EST by John Conroy
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 02:24:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Conroy 2006-11-10 22:08:20 EST
Description of problem:
When the preferred mail application is set to Thunderbird Mail, the launch Mail
Reader action opens a Thunderbird Mail compose window.

Version-Release number of selected component (if applicable):
mail-notification-3.0-10.fc6.x86_64

How reproducible:
Set Mail Reader to Thunderbird Mail in Preferred Applications.

Steps to Reproduce:
1. Make sure preferred mail reader is set to Thunderbird
2. Right-click on Mail Notification applet and select "Mail Reader"
  
Actual results:
A Thunderbird mail starts showing only a composition window.

Expected results:
A Thunderbird mail start with a main mail reader window.

Additional info:

The following process is created...
/bin/sh /usr/lib64/thunderbird-1.5.0.8/thunderbird -compose

Same results occur if you set the double-click action to "Mail Reader" and then
double-click the notification applet icon.
Comment 1 Thorsten Leemhuis 2006-11-11 03:16:06 EST
This is most likely not Fedora specific. Please report it directly to the
upstream project and its maintainers in the proper bugtracker. For
mail-notification that's at
https://savannah.nongnu.org/projects/mailnotify/
so it get's fixed there once properly and for all distributions/users; Fedora
Extras will then integrate the new version when it's available.

tia!

BTW, I'm not even sure if this is a bug in mail-notification. The
gnome-mechanisms that are responsible to start the configured mail-app should
provide a mechanism that allowes app like mail-notification to start up the
mail-app directly without a composer window.
Comment 2 John Conroy 2006-11-11 08:15:07 EST
Reported bug upstream...
https://savannah.nongnu.org/bugs/?18257

It's not distro specific, but FC has an "htmlview" package as a kludge to make
the icons works properly...figured it wouldn't hurt to get something working here.

I've tried to duplicate the functionality of the "htmlview" package in a patch I
just uploaded to the upstream tracker...
https://savannah.nongnu.org/bugs/download.php?file_id=11230

Don't know if they will accept it or not, but duplicating the info here and
reopening for those interested.
Comment 3 Thorsten Leemhuis 2006-11-21 14:19:28 EST
(In reply to comment #2)
> I've tried to duplicate the functionality of the "htmlview" package in a patch I
> just uploaded to the upstream tracker...
> https://savannah.nongnu.org/bugs/download.php?file_id=11230

Committed to devel; will build for FC6 in a few days
Comment 4 Jean-Yves Lefort 2006-11-21 15:20:08 EST
Btw: that patch will cause MN to crash if the mail reader command contains no
space at all. Since I'm going to release 4.0 in a couple of days you might want
to wait for it instead.
Comment 5 Thorsten Leemhuis 2006-11-28 02:24:21 EST
Build mail-notification-4_0-0_1_fc7_rc1 for devel -- this shoud fix this bug.
Will build the final version when ready for FC6, too.

BTW, Jean-Yves, thx for your work.

Note You need to log in before you can comment on or make changes to this bug.