Bug 215137 - [REGRESSION] nautilus can no longer access ssh:// after update
[REGRESSION] nautilus can no longer access ssh:// after update
Status: CLOSED DUPLICATE of bug 215288
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
6
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 06:05 EST by drago01
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 08:16:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drago01 2006-11-11 06:05:34 EST
Description of problem:

After updating nautilus to 2.16.2-3.fc6 using yum I can no longer access ssh://
URIs when I try this it crashes and bug-buddy trys to send a report.
I have noticed this in the xsession-error:
CRITICAL **: nautilus_directory_ref: assertion `NAUTILUS_IS_DIRECTORY
(directory)' failed
(this happens before the crash)
I have this problem on 2 different boxes and can confirm that reverting to
2.16.0-7.fc6 fixes the issue.
Version-Release number of selected component (if applicable): 2.16.2-3.fc6
How reproducible:
ALWAYS

Steps to Reproduce:
1. try to open a ssh:// URL (even ssh:// and press enter triggers this)
2. notice the crash

  
Actual results:
Crash when trying to open ssh:// URI

Expected results:
no crash like in older versions
Comment 1 drago01 2006-11-12 02:10:09 EST
it seems that  this patch broke it:

	* libnautilus-private/nautilus-directory-async.c:
	* libnautilus-private/nautilus-directory.c:
	Unschedule call_ready callbacks on directory finalize, not
	on file finalize.
	Keep monitors around until we call the call_when_ready callback
	at idle time.
	Call async_state_changed and update_metadata_monitors after
	call_when_ready callbacks have been called at idle.

	(fixes make check)
have not tryed to revert it; just was looked at the changelog and this seems the
only directory related change
Comment 2 Alexander Larsson 2006-11-13 08:16:47 EST

*** This bug has been marked as a duplicate of 215288 ***

Note You need to log in before you can comment on or make changes to this bug.