Bug 215162 - LVM tries to handle cdrom devices at startup
LVM tries to handle cdrom devices at startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm-obsolete (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Broz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 13:48 EST by Ronald Warsow
Modified: 2013-02-28 23:04 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-14 08:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2006-11-11 13:48:42 EST
Description of problem:
LVM tries to handle CDROM devices at startup

Version-Release number of selected component (if applicable):
initscripts-8.45.5-1
esp. rc.sysinit (line 449)

How reproducible:
start the box

Steps to Reproduce:
1.
2.
3.
  
Actual results:
i try to recall it from mind, cause no log entries.

Setting up Logical Volume Management: /dev/hdb: open failed: No medium found
Attempt to close device '/dev/hdb' which is not open.
No Volume Group found.

Expected results:


Additional info:
cat dmesg |grep hdb

    ide0: BM-DMA at 0x2580-0x2587, BIOS settings: hda:DMA, hdb:DMA
hdb: HL-DT-STCD-RW/DVD DRIVE GCC-4243N, ATAPI CD/DVD-ROM drive
hdb: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, DMA
Comment 1 Milan Broz 2006-11-14 08:24:27 EST
You can select filters in /etc/lvm/lvm.conf to skip scan cdrom device for volume
groups (an example is commented there).
(default is scan all block devices - due to possible change in configuration)

Second line (Attempt...) is bug fixed in LVM 2.2.07, already in rawhide, FC6
will be updated soon. 
Comment 2 Alasdair Kergon 2006-11-14 09:25:01 EST
But should a default installation skip the cdrom by default?

Would involve the startup scripts determining which is the cdrom and updating
the filters to ignore it.

Note You need to log in before you can comment on or make changes to this bug.