Bug 215174 - ALSA Errors During Shutdown
ALSA Errors During Shutdown
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 17:02 EST by Larry Johnson
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 05:42:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sound Card Detection (configuration file) (50.52 KB, text/plain)
2006-11-12 12:27 EST, Larry Johnson
no flags Details
Sound Card Detection (run session log) (705 bytes, text/plain)
2006-11-12 12:28 EST, Larry Johnson
no flags Details

  None (edit)
Description Larry Johnson 2006-11-11 17:02:50 EST
Description of problem:
During a system shutdown the alsa system reports an error and after a reboot the
volume is set to muted.  The error reported is as follows:

   get_control:149: Cannot read control info '2,0,0,Capture Volume,0': Invalid
                    argument

Also, when trying to start the amixer utility, the following error is reported:

   amixer: Mixer default load error: Invalid argument


Version-Release number of selected component (if applicable):
   Kernel: 2.6.18-1.2798.fc6
   System: Dell XPS 700
   CPU:    Intel Core 2 Duo
   ALSA:   1.0.12-2.fc6

How reproducible:
Very.

Steps to Reproduce:
1. Errors are reported during every shudown.
2. Invoked amixer from the command line.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Larry Johnson 2006-11-11 17:05:21 EST
One thing I failed to mention.  When the system boots, the sound system works. 
I get the system sounds, play music, etc.  The volume is always reset to muted
and the errors are reported during shutdown.
Comment 2 Larry Johnson 2006-11-11 17:10:07 EST
Sorry for the extra posts, maybe I will get all of the information needed here.
 The sound card detected was as follows:

   Vendor: nVidia Corportation
   Model:  MCP55 High Definition Audio
   Module: snd-hda-intel

I believe this is detection is proper.  It is integrated with my motherboard.  I
do have a second sound card installed, a Creative Labs Sound Blaster X-Fi;
however, I have not selected it as my primary sound card since there are
currently no drivers for this card (as I understand it).

Comment 3 Martin Stransky 2006-11-12 06:07:09 EST
Right, Sound Blaster X-Fi isn't supported yet.
Could you please attach /root/scsconfig.log?
Comment 4 Larry Johnson 2006-11-12 12:27:27 EST
Created attachment 140996 [details]
Sound Card Detection (configuration file)
Comment 5 Larry Johnson 2006-11-12 12:28:44 EST
Created attachment 140997 [details]
Sound Card Detection (run session log)
Comment 6 Larry Johnson 2006-11-12 12:30:10 EST
I have attached the scsconfig log as requested.  I have also attahced the
scsrun.log as it shows the error that I am receiving from amixer if I try to run
it: "amixer: Mixer default load error: Invalid argument".

Thanks for you quick response.  Let me know if you need anything else.
Comment 7 Need Real Name 2006-11-13 08:21:53 EST
I have the same error message on system shutdown.
This is on a Dell Dimension E520 with an integrated
Intel soundchip: 82801H (ICH8 Family) HD Audio Controller
using the 'snd-hda-intel' driver.

I see this with both the kernels:
kernel-2.6.18-1.2849.fc6
kernel-2.6.18-1.2798.fc6
Comment 8 Jef Spaleta 2007-01-04 01:27:21 EST
FYI

current development kernel fixes my issue with snd-hda-intel.
alsactl, amixer and alsamixer now work for me without issue.

System is a Dell  E521 Desktop currently running 32bit fedora.
with lspci reporting
Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

This is a real problem with the 1.0.12 upstream alsa drivers. I believe this is
fixed with the 1.0.13 drivers according the the alsa driver Changelogs I have
read. Who do I have to bribe to get newer upstream alsa drivers into the next
fedora core 6 update kernel?

-jef
Comment 9 Martin Stransky 2007-01-04 03:25:56 EST
I think Dave Jones makes updates for FC kernels. AFAIK he uses the latest
upstream kernels for it so the 1.0.13 drivers (or later) will be in FC-5/6 someday.
Comment 10 Larry Johnson 2007-02-17 14:39:51 EST
It appears the latest ALSA, or kernel updates fixes the issue.  I no longer see
this error during shutdown.  Thanks guys for the support. :)
Comment 11 Martin Stransky 2007-03-22 05:42:43 EDT
okay, closing.

Note You need to log in before you can comment on or make changes to this bug.