Bug 215179 - incompelete, non-informative error message
incompelete, non-informative error message
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-11 19:15 EST by Herbert Carl Meyer
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.1-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 10:09:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yumex -d output (19.72 KB, text/plain)
2006-11-12 07:03 EST, Herbert Carl Meyer
no flags Details
My output of ymex (11.68 KB, application/octet-stream)
2006-11-12 07:17 EST, J.Jansen
no flags Details

  None (edit)
Description Herbert Carl Meyer 2006-11-11 19:15:28 EST
Description of problem:
incompelete, non-informative error message

Version-Release number of selected component (if applicable):
yumex 1.2.0

How reproducible:
100%

Steps to Reproduce:
1.run yumex, select package from repo without key installed
  
Actual results:
modal error dialog, message:

Error checking package signatures:
yum.Errors.YumBaseError

Expected results:
information about whick package or repo keys are missing

Additional info:

Dismissal of modal dialog followed by exception in yumex:

Component: yumex
Version: 1.2.0
Summary: TB596a04ec yumexUtils.py:758:get_child_path_row:TypeError: could not
convert sorted_path to a GtkTreePath

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 143, in
new_pixbuf
    row = self.curView.get_child_path_row( path )
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 758, in
get_child_path_row
    filterpath = self.model.convert_path_to_child_path( path )
TypeError: could not convert sorted_path to a GtkTreePath

Local variables in innermost frame:
path: None
self: <yumex.yumexUtils.pkgView instance at 0x886b6cc>
Comment 1 Tim Lauridsen 2006-11-12 02:22:16 EST
Please run 'yumex -d' in a console and attach the output, i have som problems
reproduce the error.
At my installations the gpg keys just get imported and no errors occours.
Comment 2 Herbert Carl Meyer 2006-11-12 07:03:39 EST
Created attachment 140985 [details]
yumex -d output

yumex -d output attached
Comment 3 J.Jansen 2006-11-12 07:15:57 EST
Same error message on my machine. Signatures are not a problem, because they are
installed.

I follow the following steps

 1) start yumex
 2) select a few (i.e. 4 ) items to update
 3) run the updates
 4) when the button "OK" at the "Package process completed OK menu" (Quit works
     here as expected.
 now yumex crashes when it is updating the "Update-view"

I did run a yummex -d (output in attachment)

Additinally I got the following "errors"

[root@beer test]# yumex -d >yumex.out
/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py:345: GtkWarning: Failed
to set text from markup due to error parsing markup: Error on line 1 char 62:
Odd character 'a', expected a '=' after attribute name 'object' of element
'yumex.yumexBase.yumexBase'
  self.extraLabel.set_markup( "<span size=\"small\">%s</span>" % text )
/usr/share/yumex/yumexmain.py:1043: GtkWarning: gtk_tree_model_sort_get_value:
assertion `VALID_ITER (iter, tree_model_sort)' failed
  gtk.main_iteration()
/usr/share/yumex/yumexmain.py:1043: Warning: g_object_set_property: assertion
`G_IS_VALUE (value)' failed
  gtk.main_iteration()
/usr/share/yumex/yumexmain.py:1043: Warning: g_value_unset: assertion
`G_IS_VALUE (value)' failed
  gtk.main_iteration()
/usr/share/yumex/yumexmain.py:1043: GtkWarning: gtk_tree_model_sort_iter_next:
assertion `tree_model_sort->stamp == iter->stamp' failed
  gtk.main_iteration()
/usr/share/yumex/yumexmain.py:1043: GtkWarning: file gtktreeview.c: line 5820
(validate_visible_area): assertion `has_next' failed.
There is a disparity between the internal view of the GtkTreeView,
and the GtkTreeModel.  This generally means that the model has changed
without letting the view know.  Any display from now on is likely to
be incorrect.

  gtk.main_iteration()
/usr/share/yumex/yumexmain.py:1043: GtkWarning: file gtktreeview.c: line 6054
(do_validate_rows): assertion `gtk_tree_model_iter_next (tree_view->priv->model,
&iter)' failed.
There is a disparity between the internal view of the GtkTreeView,
and the GtkTreeModel.  This generally means that the model has changed
without letting the view know.  Any display from now on is likely to
be incorrect.

  gtk.main_iteration()
/usr/lib/python2.4/site-packages/yumex/yumexUtils.py:142: GtkWarning:
gtk_tree_model_sort_get_path: assertion `tree_model_sort->stamp == iter->stamp'
failed
  path = model.get_string_from_iter( iter )
/usr/lib/python2.4/site-packages/yumex/yumexUtils.py:142: GtkWarning:
gtk_tree_model_get_string_from_iter: assertion `path != NULL' failed
  path = model.get_string_from_iter( iter )
[root@beer test]# 


                        Jouk
Comment 4 J.Jansen 2006-11-12 07:17:06 EST
Created attachment 140986 [details]
My output of ymex

output of ymex -d
Comment 5 Tim Lauridsen 2006-11-13 02:09:00 EST
Thanks, it look like there is 2 issues here.

1. non-informative error message when a package is signed and there is no gpg
key in the rpmdb.


2. The population of the package view after something has been installed, give
strange errors.

I will dig a little deeper and try to reproduce the errors.
Comment 6 Tim Lauridsen 2006-11-13 05:13:35 EST
Try this :

http://www.yum-extender.org/dnl/yumex/testing/yumex-1.2.1-0.1.rc1.fc6.noarch.rpm

An let me know how it works.
Comment 7 Tim Lauridsen 2006-11-13 05:39:17 EST
Ups, i forgot some string conversion, here is a new one to try:

http://www.yum-extender.org/dnl/yumex/testing/yumex-1.2.1-0.2.rc2.fc6.noarch.rpm
Comment 8 J.Jansen 2006-11-14 15:52:38 EST
Did run rc2 several times. the problem did not occur
    thanks
         jouk

Note You need to log in before you can comment on or make changes to this bug.