This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 21518 - RHN Client fails to write all required records
RHN Client fails to write all required records
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
: 21513 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-30 11:06 EST by Martin C. Messer
Modified: 2015-01-07 18:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-17 10:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin C. Messer 2000-11-30 11:06:59 EST
login: bubba_jump
web_user_id: 473744

Created user using RHN client. Chose to register a system only (no product
activation.) Left all name/address info blank, including contact
permissions (email, mail, phone, fax).

Missing records:

WEB_USER_CONTACT_PERMISSION

This user will forever broken unless ALL required records are created for
him. The full list is:

WEB_USER
WEB_USER_SITE_INFO
WEB_USER_CONTACT_PERMISSION
WEB_USER_PERSONAL_INFO

For registrations, they'll need this record as well:

WEB_PRODUCT_REGISTRATION

We've been doing this for over a year now, but for some reason the process
that takes the info from NDS and desposits it in the web tables is NOT
using the same processes we know and love.
Comment 1 Martin C. Messer 2000-12-01 14:38:26 EST
*** Bug 21513 has been marked as a duplicate of this bug. ***
Comment 2 Jay Turner 2001-01-17 10:42:10 EST
The remaining issue that I know about here is the webuserfaxpermission . . .
need to at least write this record as a null.
Comment 3 Martin C. Messer 2001-01-17 10:50:43 EST
I see from the NDS dump that WEB_USER_CONTACT_PERMISSION will be written, so
this bug is no longer a problem.

Note You need to log in before you can comment on or make changes to this bug.