Bug 215243 - no driver for Realtek RTL8111/8168B
no driver for Realtek RTL8111/8168B
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 14:57 EST by Benjamin Kosnik
Modified: 2013-08-09 01:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 16:45:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Benjamin Kosnik 2006-11-12 14:57:52 EST
Description of problem:

This card is unsupported in RH kernels:

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI
Express Gigabit Ethernet controller (rev 01)


Version-Release number of selected component (if applicable):

kernel-2.6.18-1.2798.fc6
kernel-2.6.18-1.2849.fc6

How reproducible:

boot fc6, try to find network adaptor

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Patch is in 2.6.19rc1, but also on fedora-test-list in October and November:

http://www.redhat.com/archives/fedora-test-list/2006-November/msg00004.html
http://www.redhat.com/archives/fedora-test-list/2006-November/msg00000.html
http://www.redhat.com/archives/fedora-test-list/2006-October/msg00340.html
Comment 1 Răzvan Sandu 2007-01-15 03:16:57 EST
Hello,

There is a driver available at http://www.realtek.com.tw download section
(please enter "Linux driver" as search criteria and seek for 8111B) and/or on
motherboard CDs. Current version (as if January 15, 2007) is 1.05.

It compiles OK on standard kernel (make clean modules, make install, depmod -a),
but not on the kernel-xen flavour of the kernel.


Regards,
Răzvan

Comment 2 Jarod Wilson 2007-01-15 16:45:59 EST
Since its in 2.6.19, we'll inherit support when we push a 2.6.19 kernel (Real
Soon Now).

Note You need to log in before you can comment on or make changes to this bug.