Bug 215244 - no icon associated with files
no icon associated with files
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-12 15:35 EST by Patrice Dumas
Modified: 2008-02-20 22:01 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-20 22:01:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Patrice Dumas 2006-11-12 15:35:15 EST
Description of problem:

There is almost no icon associated with files and directories after
an install, except for those in hicolor. My guess was that the 
following would fix that:

[root@localhost ~]# touch --no-create /usr/share/icons/Rodent/
[root@localhost ~]# gtk-update-icon-cache /usr/share/icons/Rodent/
Cache file created successfully.

But it doesn't seems so.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kevin Fenzi 2006-11-13 15:36:16 EST
Odd. I don't see this here at all. 

The missing icons are on the desktop? Or in the Thunar browser?
You are using the Rodent icon theme? Do others work?

Comment 2 Patrice Dumas 2006-11-13 16:34:50 EST
I use fluxbox, icons are missing in Thunar. I am not using
specifically any icon theme, since I use fluxbox. In fact
having no icon in thunar may be linked with that situation, 
although I do have a .config with some things within.
I just reinstalled fc 6 and went immediately to devel. I have
recopied my home that was also on devel, I use fluxbox since I
reinstalled.
Comment 3 Kevin Fenzi 2006-11-15 16:18:59 EST
Can you try moving your .config out of the way and see if it matters?

Also, can you try running xfce-mcs-manager ? Perhaps that needs to be running to
tell Thunar what the current icon theme is?

Also, which version of Thunar is this exactly? 
Comment 4 Patrice Dumas 2006-11-16 04:03:58 EST
Launching xfce-mcs-manager, icons are added (without restarting Thunar).
My firefox widget look also changes (firefox even once crashed due to 
this... certainly a firefox bug). Killing xfce-mcs-manager, icons disappear.
So there seems to be something related with gtk theme or the like happening
here.

This reminds me of evolution taking over the whole desktop when launched...
Hope that this won't be the case for Thunar. 
Comment 5 Patrice Dumas 2006-11-16 04:04:25 EST
Thunar is
Thunar-0.5.0-0.1.rc2.fc7
Comment 6 Kevin Fenzi 2006-11-16 12:46:23 EST
ok, looks like this is known/expected upstream. See: 

http://thunar.xfce.org/pwiki/documentation/faq

The "Why does Thunar display the fallback icon for all files and folders?"

You will need to either: 
1. Run xfce4-mcs-manager or gnome-settings-daemon. 

or

2. Set the gtk-icon-theme-name in your ~/.gtkrc-2.0

I would guess that option #2 would work better for you using fluxbox... 
Does that make sense? If so go ahead and close this bug... 
Comment 7 Patrice Dumas 2006-11-16 13:16:28 EST
I would like to try an xsettings manager wm neutral before
closing this bug. I think setting gtk-icon-theme-name in
in ~/.gtkrc-2.0 is not the right solution. 
Comment 8 Patrice Dumas 2006-11-17 05:33:37 EST
There isn't such thing as a wm neutral xsettings manager. The
xsettings reference implementation is what is the closest, but it 
doesn't implement the Net/ setting names, and the element in the
Net hierarchy are not those in the standard. Moreover it doesn't have
a persistent storage, which renders it a bit unusefull.

Now regarding Thunar packaging, xfce-mcs-manager dependencies are
a subset of Thunar dependencies, and it is already an indirect
dependency for Thunar, so I think that it would be better to 
have a direct dependency of Thunar on xfce-mcs-manager, and even
better with a comment stating that Thunar needs an xsettings manager
which sets the Net/ThemeName and Net/IconThemeName to anything else
that the default theme to have useful icons associated with files.

This doesn't solve the issue completely since we need to have 
xfce-mcs-manager running on desktops which don't already have an 
xsettings daemon in order to have thunar working correctly. For that
I propose to add a file in /etx/xdg/autostart with:

[Desktop Entry]
Encoding=UTF-8
Name=Xfce settings manager
Comment= xsettings manager
Exec=xfce-mcs-manager
Terminal=false
Hidden=false
Type=Application
NotShowIn=XFCE;KDE;GNOME;ROX

It is not obvious whether it should be in Thunar or in 
xfce-mcs-manager. Indeed on the one hand there may be other 
applications than Thunar which rely on an xsettings manager running, 
but on the other hand the xsettings manager may disturb the
desktop. 

Another possibility could be to add some documentation to Thunar, 
for example in the %description or in a README to state something along

"Thunar requires a running xsettings manager which provides an icon theme
different than the default one to have meaningful icons associated with
files. Such an xsettings manager should already started in some desktops
(Xfce, gnome, KDE, ROX). In other desktops (like, for example, WindowMaker
or fluxbox) you may want to start the Xfce xsettings manager, xfce-mcs-manager
in your startup files."

It is nothing more than the textual description of the autostart file 
above... The startup file could also be shipped in that case, but with 
Hidden=true
Comment 9 Patrice Dumas 2006-11-17 05:35:18 EST
Also in the Thunar FAAQ there should be a reference to the fact that
the xsettings manager should set Net/ThemeName and Net/IconThemeName 
to meaningful values.
Comment 10 Kevin Fenzi 2006-11-17 16:17:06 EST
I would be happy to add docs, but I don't know that anyone would see them in a
readme or in the spec file more than they would searching for the FAQ on the
net. Do you really think it's worth doing so?

Adding a .desktop for xfce-mcs-manager is a bad idea. If someone is running Xfce
they would then get two instances running or errors. If they are running gnome,
they might confuse the user by not paying attention to changed settings in the
gnome tools. 

I think you might want to file a bug upstream asking Thunar developers to handle
the case where there isn't a settings manager more gracefully, either defaulting
to the Rodent theme if it's available or something else. Perhaps they could pop
up a error dialog saying "Couldn't talk to settings manager, using default
icons" or something. Upstream would also be the ones to talk to about the FAQ
suggestion in comment #9.

Can you file that upstream? Or would you want me to?
Comment 11 Patrice Dumas 2006-11-17 17:51:17 EST
(In reply to comment #10)
> I would be happy to add docs, but I don't know that anyone would see them in a
> readme or in the spec file more than they would searching for the FAQ on the
> net. Do you really think it's worth doing so?

No, I'm not sure. Better would be fixing it! Let's forget about that.

> Adding a .desktop for xfce-mcs-manager is a bad idea. If someone is running Xfce
> they would then get two instances running or errors. If they are running gnome,
> they might confuse the user by not paying attention to changed settings in the
> gnome tools. 

No, there is a:

NotShowIn=XFCE;KDE;GNOME;ROX

So this is not started in Xfce, gnome, kde, or rox.

> I think you might want to file a bug upstream asking Thunar developers to handle
> the case where there isn't a settings manager more gracefully, either defaulting
> to the Rodent theme if it's available or something else. Perhaps they could pop
> up a error dialog saying "Couldn't talk to settings manager, using default
> icons" or something. Upstream would also be the ones to talk to about the FAQ
> suggestion in comment #9.

you're indeed right. For example for people installing from source
this could also be useful.

> Can you file that upstream? Or would you want me to?

I'd prefer if it was you, it'd be more efficient. Feel free to add
me to CC in bugs at your will, however.
Comment 12 Kevin Fenzi 2006-11-20 13:38:37 EST
Filed upstream: 

http://bugzilla.xfce.org/show_bug.cgi?id=2596

You may want to add yourself to CC there. I can't do so since it won't let me
unless you have a bugzilla.xfce.org account. 
Comment 13 Patrice Dumas 2008-01-27 11:35:55 EST
This seems to be fixed. I don't know how, since I still don't
have an xsetting daemon nor a .gtk* file. Should I close the
bug or do we want to know why it works?
Comment 14 Kevin Fenzi 2008-01-27 12:27:29 EST
Strange. Could this have somehow come in with the 4.4.2 update?
I didn't see anything related in the changelogs, but I might have missed it... 

Can you update upstream and perhaps we can close this one and see if they want
to investigate further upstream?
Comment 15 Kevin Fenzi 2008-02-20 22:01:05 EST
No answer that I can see from upstream... but as long as it works, 
I will go ahead and close this. 

Feel free to re-open or file a new one if it needs any attention... 

Note You need to log in before you can comment on or make changes to this bug.