Bug 215326 - Installer crashed whike refrshing after update
Installer crashed whike refrshing after update
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
: 216329 219354 219963 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-13 10:22 EST by Michael Furman
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.2.1-1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 10:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Furman 2006-11-13 10:22:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
crashes while refreshing after update

Version-Release number of selected component (if applicable):
yum-extender 1.2.0

How reproducible:
Sometimes


Steps to Reproduce:
1.select packages for update
2.update
3.click ok

Actual Results:
crashes with message "probably a bug" - report ...

Expected Results:


Additional info:
Component: yumex
Version: 1.2.0
Summary: TB596a04ec yumexUtils.py:758:get_child_path_row:TypeError: could not co
nvert sorted_path to a GtkTreePath

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 143, in new_
pixbuf
    row = self.curView.get_child_path_row( path )
  File "/usr/lib/python2.4/site-packages/yumex/yumexUtils.py", line 758, in get_
child_path_row
    filterpath = self.model.convert_path_to_child_path( path )
TypeError: could not convert sorted_path to a GtkTreePath

Local variables in innermost frame:
path: None
self: <yumex.yumexUtils.pkgView instance at 0x8ec39ec>
Comment 1 Tim Lauridsen 2006-11-13 12:15:25 EST
Try this prereleas to see if it fixes the issue.

http://www.yum-extender.org/dnl/yumex/testing/yumex-1.2.1-0.2.rc2.fc6.noarch.rpm
Comment 2 Tim Lauridsen 2006-12-18 02:38:57 EST
*** Bug 216329 has been marked as a duplicate of this bug. ***
Comment 3 Tim Lauridsen 2006-12-18 03:09:16 EST
*** Bug 219963 has been marked as a duplicate of this bug. ***
Comment 4 Tim Lauridsen 2006-12-18 03:43:45 EST
*** Bug 219354 has been marked as a duplicate of this bug. ***
Comment 5 Tim Lauridsen 2007-01-03 10:07:46 EST
This should be fixed in yumex 1.2.1
Comment 6 Moritz Barsnick 2007-01-03 10:44:30 EST
As far as I'm concerned (as reporter of the duplicate bug #219963), I haven't 
seen this again since updating to 1.2.1.
Comment 7 Tim Lauridsen 2007-01-04 03:27:34 EST
(In reply to comment #6)
> As far as I'm concerned (as reporter of the duplicate bug #219963), I haven't 
> seen this again since updating to 1.2.1.

Sounds good, thanks for the feedback.


Note You need to log in before you can comment on or make changes to this bug.