Bug 215338 - Add a "destroy" command to virt-manager
Summary: Add a "destroy" command to virt-manager
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Hugh Brock
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-13 16:14 UTC by Chris Lalancette
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: RHEA-2007-0637
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 16:34:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2007:0637 normal SHIPPED_LIVE virt-manager enhancement update 2007-10-30 15:47:28 UTC

Description Chris Lalancette 2006-11-13 16:14:50 UTC
Description of problem:
It would be nice to have the equivalent of "xm destroy <domid>" for
virt-manager.  That way, you could kill domains that went out to lunch and don't
respond to shutdown.  It would probably also be best to have a confirmation
dialog for this, as it could be dangerous.

Comment 1 Daniel Berrange 2006-11-15 15:56:56 UTC
The other lifecycle commands have toolbar buttons, but since this is an edge
case command, its probably sufficient to add a menu option only. We should also
get the user to really confirm before destroying it since its a very destructive
operation.


Comment 2 Hugh Brock 2006-11-15 17:34:36 UTC
Fixed at:
changeset:   354:9c6d46c2f6ad
user:        "Hugh O. Brock <hbrock@redhat.com>"
date:        Wed Nov 15 12:27:36 2006 -0500
summary:     Add destroy option to details and console menus

Comment 3 RHEL Product and Program Management 2006-11-21 17:41:29 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 4 Daniel Berrange 2007-02-22 20:35:13 UTC
This fix is already upstream. Can be included in RHEL 5.1 with minimal effort.


Comment 10 errata-xmlrpc 2007-11-07 16:34:15 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0637.html



Note You need to log in before you can comment on or make changes to this bug.