Bug 215349 - cryptsetup-luks-devel header does not match library
Summary: cryptsetup-luks-devel header does not match library
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cryptsetup-luks   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Jones
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-13 16:51 UTC by David Shaw
Modified: 2007-11-30 22:11 UTC (History)
5 users (show)

Fixed In Version: 1.0.5-4.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 17:29:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Shaw 2006-11-13 16:51:31 UTC
In cryptsetup-luks-devel-1.0.3-2.1, the header libcryptsetup.h refers to the
function crypt_luksInit().  The library files (libcryptsetup.a,
libcryptsetup.so) however, do not contain crypt_luksInit().

It seems that crypt_luksInit() was renamed to crypt_luksFormat() in the 1.0
version of luks.  The library does have crypt_luksFormat(), but the change seems
to not to have made it into the header file.

Comment 1 Till Maas 2007-07-26 16:48:36 UTC
This bug seems to be still present in cryptsetup-luks 1.0.5, which is in rawhide.

Comment 2 Till Maas 2007-07-26 17:10:00 UTC
I reported this upstream with a patch:

http://article.gmane.org/gmane.linux.kernel.device-mapper.dm-crypt/2279

Comment 3 Fedora Update System 2007-08-15 19:40:53 UTC
cryptsetup-luks-1.0.5-4.fc7.1 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Fedora Update System 2007-08-29 17:29:24 UTC
cryptsetup-luks-1.0.5-4.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.